Forums > Jitter

Is there a jit.window size limit on a virtual desktop?

Feb 14 2011 | 10:46 pm

Hi there, Bonjour,

I’ve got a simple switch circuit hooked up to Max via my Arduino. The switch The PD-2-MAX part works fine, it’s banging.

I am having troubles with my [jit.window] Max-to-projector patch.

The arduino subpatch is banging the jit.noise object to create random numbers within a 256 range, and it is this ever-changing solid colour that I want to project at a 1024 x 768 resolution.

I’m using a projector with native res of 1024 x 768, at a refresh rate of (70Hz) that works fine normally. The projector connected via VGA to my PowerBook G4 ( a ppc OS 10.4.11 with MAX 5.0.5) as a virtual desktop mode. Not in mirror mode. I can even see my desktop background image…… howevs…

When I position the jit.window over onto the projector’s screen the jit.window appears, but is all black and unresponsive.

It should be changing colour with each bang coming from the arduino subpatch.


No error message.

On my iMac (intel duo core OS 10.6.6 with Max 5.0.5), this patch works great.

But I need to use my PowerBook G4, since this patch is part of a week-long installation.

In trying to troubleshoot the problem, I have found that Max creates a responsive [jit.window] as long as it stays on the G4’s side of the virtual desktop. After that, all black. Nothing doing.

The [jit.window] will appear and change colour on the projector’s side only if the size of the window stays below 1024 and 700 somewhere. If the window gets sized bigger, it truns completely black and no longer changer colour.

If I size the jit.window down to say… 200 x 475 it works again (it changes colour on both desktops)

I’ve tried changing the refresh rates on the projector itself, but that didn’t do anything.

There’s no other [jit.window] or jitter patch going on in the background.

I ‘ve attached my patch to this post, if anyone wants to a give it a try.

Thanks for any help you can offer. Merci d’avance!

Feb 15 2011 | 4:26 am

My solution so far:

I reduced (in Display Preferences) the projector’s resolution to 640 x 480. I correspondingly changed the gemwin dimensions to 640 x 480.

Since I was hitting some kind of jit.window dimension limit around 700 pixels, this now outputs an entirely coloured screen… and that’s what I want :)

I’m still curious as to why I couldn’t seem to have a jit.window larger than 700 x700 on my virtual desktop, like to the 1024 x 768 resolution of my projector…… hmmm….

I had this very same problem when I made a version of this patch in PD-extended 0.42.5. I "solved" it the same way in both cases.

Feb 15 2011 | 4:27 am

oops I meant this-a one.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums > Jitter