Forums > Jitter – Need loadram to send out a 'loaded' message

Aug 27 2008 | 8:45 am

I have a question about the

The patch I’m working on contains three objects.
Every time a keys is pressed, three movies are (randomly) read in these objects from disk. After the reading is done, I send all three objects the ‘loadram’ message (for speed).
Then, after the loading to ram is done, I like to play the movies simultaneously.
But here comes my problem: I need to give me a message that the ‘loadram’ is done. Because when I start the movies too early (while the loadram is still in progress), the images stutter a lot.

I searched everywhere before posting (my first post!)
Any help on this?

Thanks in advance! Daan

Aug 29 2008 | 3:06 pm

I found the answer after posting the previous message: using asyncread instead of read. That generates a ‘read’ message as well.

But now I have a new problem:
The asyncread message often generates an error message:
‘error: error -108 creating new movie from file’

I tried reinstalling max/msp/jitter 4.6,
I tried the incremental update JitterAPI.framework 1.6.4-x2,
I also tried Max 5 Runtime (which gave me the message ‘error -50 creating new movie from file’),
but nothing helped.

Sometimes it works in Max/msp/jitter (runtime), most times it doesn’t.

Help! I’m on a deadline. I hate having to resort to matrixsets..

Thanks, Daan

Aug 29 2008 | 5:12 pm

please provide relevant info and a patch to reproduce, and someone will take a look.

if it only happens with specific movies, a link to one of the movies would be helpful as well.


Please report any problems you experience with clear and complete
information, including steps to reproduce, software and system
information, and where possible, an isolated example patch and crash
log. Something like the following would be ideal. This makes it
easier for us to find and fix the problems you experience. Without
such clear and complete information, it is less likely we will be
able to.

Provide a descriptive summary of the issue.

Steps to Reproduce:
In numbered format, detail the exact steps taken to produce the bug.

Expected Results:
Describe what you expected to happen when you executed the steps above.

Actual Results:
Please explain what actually occurred when steps above are executed.

Describe circumstances where the problem occurs or does not occur,
such as software versions and/or hardware configurations.

Provide additional information, such as references to related
problems, workarounds and relevant attachments.

Sep 01 2008 | 11:36 am

Hi Daan,

This is a bit of a guess, but could be useful to rule out:

I’ve encountered a problem with quicktime refusing to create cache files over 32 characters in length. The error code was not -50; it might have been -37 or -38. Anyway this was with loading mp3 files utilizing spigot~(soc).

You might want to confirm the filename isn’t causing any trouble by choosing very simple names like


Sep 02 2008 | 8:46 am

Hi Rob and Anthony, thanks for your interest in the matter.

I seem to have solved the issue. Suddenly it struck me that maybe Jitter wasn’t the problem, but the Quicktime movies.
So I tried some other movies and the error message disappeared.

Still a little strange because the movies I used seemed perfectly normal. This is what I did to reproduce the error:

I use Max/MSP 4.6.3 (with Jitter 1.6.3) on a MacBook Pro, 2.33 GHz with 3Gb RAM, running OSX 10.4.11. I made a patch with only one object and a message box with ‘asyncread’ connected to the object.

Then I tried loading my ‘problem’ movies (which were made using Quicktime Pro 7.5 and the webcam on the laptop, saving them ‘self contained’).
Then when I tried loading the movies, often the error pops up:
‘error: error -108 creating new movie from file’.

Just now I tried making new movies with Quicktime and reproduce the error but was not able to.. Hm, funny.

Don’t know if all this helps, but I just wanted to give a follow-up on my previous post.

Greets! Daan

Sep 09 2008 | 11:35 am


The BUG is back again!

Initially my patch has been working well since I got the new movies from my friend (just normal 800*480 DV-PAL movies) but now suddenly after weeks without problems, I’m getting the error again. It happens when I ‘asyncread’ a movie into

‘error: error -108 creating new movie from file’
(in Max/MSP/Jitter 4.6.3 with Jitter version 1.6.3)


‘error -50 creating new movie from file’
(in Max/MSP/Jitter 5.0.4 Runtime, with the latest Jitter version I guess, I just downloaded it so..)

I could even reproduce it with the basic patch at the bottom of this post.
It might be an idea to send you a problem movie (probably too large for on he forum) but since those movies have not been touched since I got them, I guess the problem is elsewhere..

My computer:
MacBook Pro 2.33 GHz with 3 Gb RAM running OSX 10.4.11

Thanks in advance! Greets Daan

max v2;
#N vpatcher 115 113 288 255;
#P window setfont "Sans Serif" 9.;
#P window linecount 1;
#P message 11 29 56 196617 asyncread;
#P newex 11 52 63 196617;
#P connect 1 0 0 0;
#P pop;

Sep 09 2008 | 11:52 am

Please upload one of the movies with the problem where I can find it. Can’t reproduce using example media files (but OS X.5.4 here).


Dec 29 2009 | 10:26 pm

Did anyone ever find an answer to this problem? I’m having the exact same problem. Some movies cause my asyncread to throw the same errors.

Jul 30 2010 | 11:23 pm

Is anyone figured how to solve error -50?


Luis Marques

Jul 31 2010 | 5:25 pm

Since asyncread works in another thread, I assume you are trying to load a file whose codec is not threadsafe.

A list of threadsafe and non-threadsafe components is listed here:

Viewing 10 posts - 1 through 10 (of 10 total)

Forums > Jitter