Forums > MaxMSP

kore player vst help

May 31 2011 | 10:50 pm

So, apparently I can’t figure out anything on my own.

Goal: Load up a patch and have one of the Kore Player presets load.

– pgmnames – tells me it’s abyss flowers. obviously it can’t find ‘abyss’ using a "read" msg so just to see if it’s working I pick one with only one name. Doesn’t work. This confuses me. Did I get the program name Abyss Flowers, but it’s not really a loadable program? wha?

-I tried sending it "write" and wrote an abyss.fxp file. tried to then "read abyss.fxp", no luck.

-even though I know this wouldn’t work when loading the patch, I even tried "set abyss" and then reading that. Nothing happened, not even an error.

Jun 01 2011 | 2:58 am

I am pretty sure that if you save an fxp file it save the
current state of your VST.

If it is of any help, here is the patch I use with Kore.
Hope it is helpful.

-- Pasted Max Patch, click to expand. --

Jun 02 2011 | 1:40 am

neat patch! clean =)

Well, I don’t know why, but it’s working now. at least when it loads. I think the problem was that I had automated the x+y controller that blends the timbre’s together on, so maybe it confused the write? :shrug: THANKS!

Jun 02 2011 | 1:52 am

new problem – when building an application, it doesn’t want to load kore.vst =,( this makes me sad. even when I add it explicitly.

Jun 02 2011 | 9:19 pm

ahhh!!!!! this is frustrating. the only way to load it is to use the "plug" message and select it in finder!!!! I can’t even just "plug kore.vst"

Jun 02 2011 | 9:31 pm

selecting it in the finder does exactly the same, it also results in a message "plug filename" into [vst~]

"plug kore.vst" sounds pretty wrong btw, except your copy of kore is called "kore.vst.vst", which i doubt.



Jun 02 2011 | 9:58 pm

anytime I reference files I always use extensions. Why would using "plug kore.vst" put 2 .vst extensions on the request? Also, "plug kore.vst" works fine when using max/msp; not after I’ve build the application.

thanks for your help!

Jun 03 2011 | 3:38 am

Not sure why "plug kore.vst" works.

This works for me as a patch and as a standalone, I have an actual Kore somewhere if we find out it makes a difference.

-- Pasted Max Patch, click to expand. --

Jun 03 2011 | 6:03 pm

ok. using [vst~ kore] doesn’t work. using "plug kore" doesn’t work. my way using extensions doesn’t work. Using standalone and ‘search for missing files’ doesn’t work.

for some reason I got rid of my "kore.vst" and re-copied the original "Kore Player.vst" and used exactly what you put, and it works….. can someone explain why?

And why this happens?

"vst~: can’t find plug-in, using default
vst~: The 1 parameter of Default is:
vst~: Gain
vst~: Kore Player.vst has 130 parameters"

I’m using a blank [vst~] object and the only time I load a vst~ is with the message "plug Kore Player"

thanks man. I really appreciate your help

Jun 03 2011 | 6:17 pm

"plug Kore Player" is syntactically wrong.

plug "Kore Player" is what you want. The vst~ object knows where your system VSTs are and to append the file extension, but for VSTs with multi word names the argument to load them must be a symbol.

The messages you see in the Max window are the result of initialising the vst~ object with no arguments and then correctly loading Kore Player.


Jun 03 2011 | 11:31 pm

@Andrew – yes, in the above example I should’ve listed it ‘plug "Kore Player"‘, even after you gave me that example I missed it and was confused 0.o. Thanks for clarifying the max window also. I’m trying to make this patch as streamlined and light as possible. I really appreciate it!

Viewing 11 posts - 1 through 11 (of 11 total)

Forums > MaxMSP