Forums > MaxMSP

Load a patch in Runtime from Max 5…? Shell ?

Jun 12 2009 | 1:03 am

Hi everyone

I’m programming a patch sending video from Max 5 — via — to some other patches in Runtime, for CPU reasons.

I choose in the main patch where in runtime the video will
be sent.

I have 2 problems :

1. Simply to open the patches I want the first time it is selected, that may imply to open Runtime too. That could be done with shell commands like this one : "open -a path-of-runtime path-of-my-patch"
Since I am a newbie with the terminal, I may have done some mistake but it didn’t work when I tried, even by calling scripts.

2. Even if that first part would work, sending the same command n times would load n instanciations of a same patch in runtime…

Do you have an idea to solve this little problem ?
Thanks in advance, best

Jun 14 2009 | 4:14 pm


So the following command does not work in your terminal? :

open -a '/Applications/Max5/MaxMSP' '/Applications/Max5/Cycling '''74/max-help/abs.maxhelp'

Why do you have to send "the same command n times" if you don’t want "n instanciations"?


Jun 14 2009 | 6:22 pm

Hi Ch.

Thank you for answering.

Actually, I wanted to use a shell command that could act like ‘front’ messages for the ‘thispatcher’ of my abstractions, but from Max to Runtime…
(I know that the command I proposed wasn’t really appropriate.)

Since my first message, I decided to group every of my runtime abstractions into a kind of floating menu window.

So my only remaining problem is to call this window with a unique shell command with a loadbang in the main patch?

I tried with the two shell objects I found on maxobjects, but the command seems to be too much complex for them.

Does it work if I add quotes like you did in your post?
With which object ? Orcutt’s one or Akamatsu’s one ?
(I don’t have Max here to try)

Thanks again


Jun 15 2009 | 9:25 am

You have to add some quotes around a path if it contains some blank caracters :


I just tried the command I posted in my previous post with It does not work cause of the quote caracter in Cycling ’74. but there’s probably a way to make it working…

anyway, the following command works nicely with :

open -a '/Applications/Max5/MaxMSP' /Users/charles/Documents/aPatch.maxpat

you have to add some quotes (" ") arround the command to send it directly to :

— Pasted Max Patch, click to expand. —


Jun 15 2009 | 10:21 am

Thanks very much Charles
I will try this out tonight.



Jun 25 2009 | 6:42 am

Thanks very much Charles, I tried it only
now and it works perfectly !



Viewing 6 posts - 1 through 6 (of 6 total)

Forums > MaxMSP