Forums > MaxMSP

Malfunctioning sends and receives.

Nov 06 2009 | 1:47 pm

I have a patch wich contains 128 sends and 128 receives in total. These are all in pairs of one receive and one send.

About 5 or 6 of them are not working:

I send a message trough them with the word ‘replace’ prepended (as in the object [prepend replace]) and for some reason this isn’t received by the receives of the malfunctioning cases.
When i bypass the prepend object it works perfectly for some reason.
This system is used 64 times and for all the other ones it works perfectly with replace prepended.

I would post the patch if it wasn’t so big so you could try to reproduce it but maybe someone has experience with this problem and can suggest a solution without reproducing.

I think it has something to do with the fact that I’m using so many sends and receives in one patch but replacing them with cables would be terror.

Max 5.0.8 OSX 10.5.8

Nov 06 2009 | 2:00 pm

i had trouble with (send) and [receive] before, plus the msp ones. the problem i had was that one or two were accidentally labeled wrong, either being from a slip of my finger on another key or something similar.

i have had patches with have many-a-send. but have not run into problems with the objects themselves, more just a problem of me labeling wrong.

my best bet, which sounds cack. is go through each different send etc, and just check if any labeled wrong [same with the receive as well, also a good way to check send and the such is double-clicking on them, a little window pops up to see if it making any connection to a receive and visa-versa.

hope this helped, but as i said, i have not had that sort of problem with the object, only my own mistakes…

Nov 06 2009 | 2:30 pm

Thanks for your suggestion but I’ve checked the labeling very good. When i double click on the sends and receives I can see their sending or receiving buddys.
I even tried making a receive right next to the send in case wich has the exact same result.
But as I already mentioned, when i dont prepend ‘replace’ to them message it works fine.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums > MaxMSP