Forums > MaxMSP

Max 6 painfully slow startup on Windows

March 16, 2012 | 6:21 pm

Just upgraded Max 5 to Max 6 on a fast Win7 workstation.

Especially the first startup of Max after a reboot, slow as hell, takes minutes. (Max 5 on the same machine was fine) Is it just me, or some tricks exist tweak this?

P.S. Still love the new features.

March 19, 2012 | 8:38 am


Most likely something to do with your soundcard config, since we upgraded to Max 6 we’ve been getting the same problem, there are also a whole new lot of settings in the dsp status patch. If you use Max 6 in conjunction with Avid firmware it is even more likely that you will experience slow loading times.

You can try to remove some of the new Jitter objects to speed up the process however it’s inadvisable.


1st Creative Labs

July 2, 2012 | 3:56 pm

Same problem here, and we’re clearly not alone… (just to bump the thread in the hope cycling will fix this or to know if someone has a workaround)

July 2, 2012 | 4:32 pm

We’d like to have a look at this in some more detail.

I wonder if I could ask you guys to send us zipped copies of your preferences folders.

If they’re too big to send via email, get in touch with us and we’ll arrange something.

Preferences are stored here

c:UsersYour usernameAppDataRoamingCycling’74

Please note that "Application Data" is an invisible folder and may need to be made viewable.

Please send this folder, or otherwise get in touch with support at cycling74 dot com



July 2, 2012 | 7:47 pm

Same here. I think this is more common than an exception. Maybe its OS related: Windows 7 64 bit.

July 3, 2012 | 4:51 am

Thanks Andrew,
I tried to rename the folder to see if it could be related to my settings but the startup is as slow as before, anyway here it is (on dropbox) :

July 3, 2012 | 9:39 am

I’ve got some problems with launching Max too, but I’m on Max OS X 10.5.8. Max 6 crashes on startup quite often here.

Maybe I shouldn’t be posting this here since it’s about startup on Windows, but yeah…

July 3, 2012 | 2:12 pm

would like to be able to say same here but in my case with Windows 7 (64-bit), Max 6 just seems to get stuck in launch & never quite able to make it. no problem with Max 5 on the same machine though.

any help would be much appreciated. :)

July 3, 2012 | 2:20 pm

If Max 6 seems to not launch at all, please first check the task manager.

If you can see the process starting and then disappearing, it’s crashing – please contact support to get help.



July 3, 2012 | 2:23 pm

Max does launch slow for me as well. Win 7 64 bit.

July 3, 2012 | 4:37 pm

@Andrew I just made a test, Max stays in the task manager and the memory slowly rises until it reaches around 90Mo then it appears.
The problem is that Max does 0-90 in around 2’23 on my machine…
For the comparison I looked for another application on my system that had an equivalent memory load, the first application I found was my old Kontakt 4 and it loads in approx. 6 sec (for 89Mo)

July 3, 2012 | 5:07 pm

Another ask.

May we please get console output from these slow startups?

To get console output on Windows , please grab a copy of DBgview

Run it before trying to start Max. Copy all the output you see from the Max app and email it into support or pm me with it



July 3, 2012 | 7:27 pm

PMed to you.

August 15, 2012 | 10:43 am

same here, files are sent by email :)

August 15, 2012 | 2:19 pm

I get this on all my computers, two 64-bit, one 32-bit, all running Win 7, all Thinkpads. I think my problem might be related to that Max searches for my Motu Traveler external firewire interface, which I rarely use. Do you guys still want the data?

September 9, 2012 | 4:38 pm

I have the same problem here with Win Vista (32-bit) and Win 7 (64-bit)
Preferences files upload to DropBox
Anticipating a solution.

September 24, 2012 | 5:26 pm

Bump~~ any response from Cycling74 yet regarding this? Still running slow whenever opening it on Win7 now…. Thx!

September 24, 2012 | 5:28 pm

For me it’s quicker after installing 6.0.7… with 6.0.5 it it took 4 mins, now it only takes 2 mins… what’s still a lot, but better :)

November 7, 2012 | 12:53 pm

having the same problem.
any news on this?
max6.0.7 shows up in the task manager and the memory slowly rises until it reaches around 90Mo (like Error_500 described).
i think this happend since i put my whole max stuff to a dropbox folder and added it in the search path.
maybe the problem is that there is also the whole mac osx stuff in the folder. on my mac max starts just fine.
sorry if this is offtopic but what would be a good way to organize libraries, objects patches and stuff in order to access it via two computers and two different operating systems i.e windows and mac osx?

November 7, 2012 | 12:57 pm

this also affects my ableton projects which are loading bloddy slow when max for live is used. i changed m4l to use max5 again and it loads faster.

November 15, 2012 | 10:07 pm

Apparently they’re working on the issue. I know on Mac computers Max is affected by Avid MIDI drivers. I have Pro Tools 8 installed along with Max 6 on my Macbook, and Max would start really slowly but I was able to fix it. It involves changing the drivers you use for Pro Tools (even deleting them… if you search around on google you’ll be able to find other forums with how to fix it). I was wondering if it is the same on Windows. On my Mac, Max worked fine when Pro Tools wasn’t installed, but with the fix it is ok. I haven’t been able to uninstall Pro Tools as it’d be a bit of work for me to get it all installed as 8.5 again… Windows structure is different than Mac, so not sure how one would go about correcting any driver problems on Windows.

November 15, 2012 | 10:07 pm

I sent Cycling support an email about it yesterday.

December 16, 2012 | 4:57 pm

Max 6.0.8 and Max 6.1 here both slow as hell on Windows 7 64 bit.
Max4Live both on Live 8.3.4 and 9 ( beta ) is even slower…a pain in the ass. Unusable.
I use to get pretty slow loading times but now they are in the order of 5 – 10 mintues.
And i don’t know why.

January 8, 2013 | 11:47 am

Max 6.0.7 on a Windows 7 machine will take around 1 minute to start after a fresh reboot
That is on a pretty ‘clean’ system with lots of crap processes terminated (e.g. adobe and chrome updaters etc.)
It takes around 22 seconds on second launch.

Here are the debugview outputs respectively for start after fresh reboot and second launch:

It seems the critical bottleneck is path_buildcache whatever that is. My guess is it has to do with autocompletion etc. Maybe it could be done on demand?

January 31, 2013 | 10:04 pm

Hey, I also had problems with Max running very slowly and taking ages to start up (windows 64bit). Fixed by turning off my firewall and running as admin, works perfectly now. It also helps to run using your graphics card for some reason it wasn’t automatically doing that.
Hope this helps.

March 11, 2013 | 12:36 pm

I’m having similar issues; startup can be as long as 10 minutes and it often takes 3 – 8 attempts to get it to open at all. I also get an APPCRASH error whenever I close it (relating to Quicktime, according to the Windows error log).

Note that the startup issues have been present since installation.

My system specs:
Intel Core i7 2670QM
GT 540m 2GB
Realtek audio with ASIO4ALL drivers

March 11, 2013 | 6:38 pm

I believe that the majority if problems with this issue have been solved in Max 6.1. Please let us know if you experience otherwise.


Viewing 27 posts - 1 through 27 (of 27 total)

Forums > MaxMSP