Forums > Jitter

Max.exe crashes on startup

Apr 22 2007 | 1:44 am


I’ve been working diligently on the same set of patches for a few weeks but I hadn’t this past week while I worked on other things. I came back to Max to find that when launched it begins to load, then I see Jitter loaded in the status list, and then it just straight crashes. The entire program disappears without an error or message.

Uninstalling everything and reinstalling just MaxMSP works. But when I install Jitter it crashes during program launch. I am running 4.6.2 and 1.6.2.

What the heck could have happened and how can I fix this?
Thanks for your help,


Apr 22 2007 | 1:53 am

To shed some further light on this issue…

A few days ago I had to re-install the AdobeCS2 suite, but my C drive had less than 1.5GB available space so the installer wouldn’t proceed. Stupid, I realize, especially because my other partitions have gigabytes of space free, anyways I used a tool called unstoppable copier to move my user directory and program file directories to another drive temporarily. If the program couldn’t move a file for whatever reason, e.g. Windows complaining it can’t be moved, it just left it alone. This way when I got the installer running I could copy the files back and everything would be in its place, even the "unmovable" files.

All of my other programs are working without issues but I’m thinking that this may have screwed my Max/Jitter install. I’ve uninstalled both programs, deleted every related folder I could find, but I must be missing something because Max doesn’t pester me to authorize after I reinstall, it just boots right up. What files/registry settings and I missing?


Apr 22 2007 | 1:53 am

Are you on Windows XP?

I found this problem recently, and was able to fix it.

Basically, a new version of Java (v6) is incompatible with Jitter, and causes a crash on startup. Fortunately, it is easy to fix. I think this problem is specific to Windows only, but it may affect Mac OS X as well. Please check.

You can check that this is the case by going to the Cycling ’74 folder, and temporarily moving the java folder out of it. Max + Jitter starts normally after this, you may have this problem.

The problem: Java may update itself automatically, and install the incompatible version. When it does so, Max will start, but then close before showing the jitter window.

The fix:

1) On Windows, find the file C:Program FilesCycling ’74MaxMSP 4.6Cycling ’

2) Open it with a text editor (Wordpad works best)

3) Find the line that says: max.jvm.option -Xms16m

4) Change it to read: max.jvm.option -Xms64m

5) Save the file

Max should start up and work normally after this.

Alternatively, download and install v5 of the JRE from here:

And turn off auto update so that it doesn’t bite you in the ass again.

Apr 22 2007 | 1:57 am

HA! That did the trick. And yes, editing in wordpad preserves the line spacing making it easier to edit, for you doubters out there.

Fantastic. How did you figure this out?

Thank you!

Apr 22 2007 | 2:04 am

My Max install stopped working out of the blue, and the only thing that had changed was an automatic update of Java. With some help, I confirmed that Jitter was failing when trying to load Java related extensions.

A related thread on this forum about Vista compatibility also led to insufficient memory allocation for the Java VM as a problem.

So I changed the setting to allocate much more memory to the JVM on startup, and that seems to work.

I am glad that this is working for you! Spread the word, as I suspect that this will pop up very often as the automatic update spreads to more machines.

Apr 22 2007 | 12:05 pm

When it happened to me, I’ve just come to the same conclusion, but had a different solution:
I went to Control Panel/Add or Remove Programs, and removed Java Runtime Environment 6. You don’t need to re-install version 5 because version 6’s installer/updater doesn’t remove it.

May 07 2007 | 4:02 pm

You Heroes!! This was driving me nuts, thanks a bunch you’ve made my day!


May 07 2007 | 4:06 pm

Quote: Fenrik wrote on Mon, 07 May 2007 10:02
> You Heroes!! This was driving me nuts, thanks a bunch you’ve made my day!
> cheers,
> F

Windows or Mac?

May 07 2007 | 6:20 pm

windows, just editted that as described above and it worked a charm! Thanks again!

Viewing 9 posts - 1 through 9 (of 9 total)

Forums > Jitter