Forums > MaxMSP

Max MSP to Ableton Issue "awaiting pick up"

Nov 05 2011 | 2:27 pm

Hi guys,

My first post so please be gentle with me!!!

I’m integrating the Wii remote into a Max MSP and using it in Ableton Live. I’ve got the Wii data into the project via the OSCulator. its mapped all the values to Max and I have set-up arguments that sends the button output bangs into Ableton to trigger scenes and switch on/off effect devices. The main problem I have now is using the pitch/roll/X,Y,Z data. I’ve set up scale objects to make use of the data in max and i’m outputting to ctlout objects to ableton, the issue i’m having is: I can map the CC number fine but when i try to control the movement in live, Ableton says ‘awaiting pickup’ this usually happens while Ableton latches onto the the correct value, so what I think is happening is the values I’m sending Ableton aren’t correct for it to control the device. Any help would be appreciated,

Thanks in advance, Elliot

Nov 05 2011 | 2:58 pm

are you doing this in M4L or through the IAC bus/MidiYoke?

first thing to test is to turn off pick-up in Ableton Prefs – set it to instant or whatever and see if any numbers are getting through.

Nov 05 2011 | 3:11 pm

Hi Grizzle, thanks for the quick reply.

Not really sure what you mean by the M4L or IAC bus/midiYoke, sorry. My control out object 'ctlout 60' output is set to 'max msp 1' into ableton and I have the midi preferences input from max msp 1 'track & remote on' the same for max msp out.As far as I can tell its all mapping fine as CC 60 shows up when I click on a devices knob etc.

I'm using the Ocsulator 'wiimote to max' standard patch and the Wiimote to max, max msp patch that I'm adapting.

I've tried the different 'take over' modes in the preferences to no joy, when I change it to value scaling nothing happens, thanks in advance, Elliot.

p.s please find attached max patch if it would help


Nov 05 2011 | 5:13 pm

I checked it out and it works the way you said. It just worked so I am not sure what to say. It looked like it was waiting for pick-up so I changed take-over mode to none then it picked it up and after I switched it back it worked also. I tried it with maxmsp midi out and the IAC bus and both worked fine.

In Ableton I have MaxMsp1 set to remote in only (not track not that it should matter) and I did not engage the Max outs at all in Ableton (this might matter but I didn’t check.)

Try again if it doesn’t work try another machine.

Nov 06 2011 | 11:21 am

Hi Grizzle, thanks for the reply, thats still not working. maybe its my machine. could you save and attach your ableton project file, with your preferences setting, thats prob the only other thing I can think of, If not I’ll need to try on a different machine next week, your a star, thanks. Elliot

Viewing 5 posts - 1 through 5 (of 5 total)

Forums > MaxMSP