Forums > MaxMSP

max to shell

Feb 21 2010 | 4:56 pm


i’m having problems in finding a way to have max communicating to a unix shell.
I’d like to be able to send unix commands inside max.
i foud two externals ( and shell), but seems to be very instable on Max 5 and the other one doesn’t work on intel macs.
How could i solve it?

Feb 21 2010 | 5:18 pm

I have [shell] working fine on an Intel machine. I’m not sure where I found my version, I think perhaps there’s a link on the Cycling share page.


Feb 21 2010 | 5:30 pm

thanks Luke,
I found the UB version here:

but i am tinkering a bit with it, and i notice someting wrong…
i’d like to burn a cd, but the commands which work on a mac terminal doesn’t work here…
this is the command that burns a cd
" drutil burn -audio myfolderwithaudiofile "

but when i connect this message to a [shell] object i get each time this error:
"the burn failed because of a medium write error"
what could this be?

here’s my little thing

-- Pasted Max Patch, click to expand. --


Feb 25 2010 | 10:29 pm

ok, i found that it was simply my optical lens! it seems that my mac started misbehaving like, *the same moment* i tried to burn a cd with max [shell]. Digital mysticism.

now I discovered that at least *once* it did work with Max… so i assume it will *always* when i clean my lenses.
by the way… i found a little glitch i cannot resolve. hope someone know what it is, for i have no experience with shell at all…

The problem is that if it doesn’t burn the cd the first time i send (drutil burn etc… ) – after it gives me that error and ejects the cd – it will never accept the same command again.
I put a new blank cd, and nothing happens if i send that command again…
So, do you think is there some command i should use before, or after sending a (drutil burn -audio myfolder)?

UPDATE: to make it simple: Max is freezing. it simply stops responding

Feb 26 2010 | 12:41 am

update: maybe this is helpful for someone. the issue is partially solved…
the problem is this: when a cd fails to burn, drutil (and draudiotool: terminal commands) remain opened, waiting for someone to put a good cd inside. If that doesn’t happen it will never stop. Freezing Max until that is resolved. So… I’m trying to figure out a way to stop it anyway from Max but it’s only because now i’m in the fight (from terminal i just need to write "killall draudiotool" and "killall drutil" and the freezing is fixed)…. It’ll make no difference btw, because it only waits for a good cd to burn it.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums > MaxMSP