Forums > MaxMSP

MaxMSP 5 – MXJ on Snow Leopard 10.6.3 (problems with MaxSystem.* commands)

April 23, 2010 | 6:11 pm

Hi there,

I am having some strange issues with MXJ since upgrading to Snow Leopard. Basically, almost any static calls to MaxSystem.* simply never complete, and give no error messages on the or in the max window. I’ve tried to catch exceptions and just can’t find anything.

I re-installed Java 1.5 (per these instructions and have tried the programs on 1.5 and 1.6.

The example program runs fine on 4.6 (which is still on my machine). It runs fine on MaxMSP 5 on windows. It runs fine on MaxMSP 5 on OS X 10.5.8.

It just won’t run on 10.6.3!

I’m beginning to wonder if there is some issue with MXJ JNI calls? Perhaps there is a 32/64 bit problem with the JNI library?

Anyway, I am enclosing the source, class, maxpatch 4.6 and 5.0 files for your testing. If you are on Snow Leopard could you try it out?


April 23, 2010 | 8:22 pm

So I just tried this on another Snow Leopard machine and it seemed to work. Can anyone think of any reasons why the MaxSystem.* calls wouldn’t be working on my machine?

April 23, 2010 | 9:23 pm

Another update — after configuring the mxj JVM to output like

max.jvm.option -Xdebug
max.jvm.option -Xnoagent
max.jvm.option -Xrunjdwp:transport=dt_socket,address=8074,server=y,suspend=n
max.jvm.option -XX:-UseSharedSpaces

and connecting to the the output via:

jdb -attach 8074

it reveals that:

none:~ bakercp$ jdb -attach 8074
Set uncaught java.lang.Throwable
Set deferred uncaught java.lang.Throwable
Initializing jdb …
Exception occurred: java.lang.UnsatisfiedLinkError (uncaught)"thread=AWT-AppKit", com.cycling74.max.MaxSystem.locateFile(), line=-1 bci=-1



etc etc.

Any tips? I get unsatisfied link errors on all "native" java calls within the max.jar.

April 25, 2010 | 4:56 am

Well, I finally solved it. Turns out that a copy of the 4.6 max.jar and jitter.jar were in the /Library/java/Extensions folder. No idea how they got there, but they were the culprit. Thanks to JKC for the tips.

Viewing 4 posts - 1 through 4 (of 4 total)

Forums > MaxMSP