Forums > MaxMSP

Maxuino and max 5 (pmw ports dont work?)

Apr 12 2014 | 11:20 am

I have a question:
I want to use maxuino to connect my arduino to max/msp.
When I want to control e.g. a servo motor it uses the [live.slider] object.
As you may know – the [live.slider] object exists only in max 6 – I have max 5…
Is there a way to replace [live.slider]? I already have tried [float] and [slider] but with no succes.
(I want to control through max/msp my arduinos the pwm ports and a stepermoter)

(second) Why does this not work? (blue circled methods).
If the slider and float doesn’t work, than (according to my ‘logic’) than a message object [analogWrite 9 0.5] should work – right?
But sadly it doesn’t. Can you tell me why?

My Arduino is connected correctly. I tested through Firmata_Test.exe ( and everything works. The digital output works through maxuino – even at pin 9 (digital).
sorry for my english, i’m not a native speaker but I do my best :)
Thanks in advance for your help!

  • This topic was modified 2 years by  qwertis.
  • This topic was modified 2 years by  qwertis.
  • This topic was modified 2 years by  qwertis.
  • This topic was modified 2 years by  qwertis.
  • This topic was modified 2 years by  qwertis.
  • This topic was modified 2 years by  qwertis.
  • This topic was modified 2 years by  qwertis.
Apr 12 2014 | 11:45 am

in this example patch, the live.slider object is configured to send float values from 0. to 1.
just configure you regular max slider object to output the same range of value and it should work the same.

Apr 13 2014 | 2:36 am

Thanks for you replay!
Unfortunately, I have to say that it doesn’t work for me.

Also, i found it strange that the green circle messages work, but the red ones doesn’t…
I think maxuino can’t handle pmw ports? That’s strange… I use Maxuino_b017

  • This reply was modified 2 years by  qwertis.
Apr 14 2014 | 6:27 am

Update: I also tried it on another arduino – that one it doesn’t work also as it should..

Apr 14 2014 | 8:30 am

Can you double click on the "maxuino c" object in the help patch, check the box for debug, then try the "pinMode 9 3" and "analogWrite 9 0.7" again and post what it says? We have not been Max5 compatible for a couple years so it could be any number of internal things…

Apr 14 2014 | 8:42 am

if I may . . . .

please post patches not big pictures; formatting on the site is all messed up here

Apr 16 2014 | 6:31 am

Hello Cole, thanks for helping me! I appreciate it! :)
This is what I got:

1078to-maxuino.js: pinMode 9 3
js: *** WARNING ***: For pin 9 Firmata reports this as an invalid pinMode
1078from-maxuino.js_SERIAL: 244 9 3
p.s. I also tried pin 10, same result

@N00B_MEISTER; I used images because if i use patches you could not see (instant) the same result i get. As where your max version, arduino and pc (could) be different. I think the formatting is oke, but I will keep it in mind.

Apr 27 2014 | 2:53 pm

Mark, it seems that either you have not hit the "init" button or that your arduino is not being read properly? The init button sends a command to ask the arduino what its capabilities are and it seems it is not getting info back that pin 9 can do pwm (even tho, it should still be able to do servo.)
Please download the Firmata test program here: and make sure that pin 9 is fully working in that program first. If neither of those things fix the problem, I am not sure what else to try.

Viewing 8 posts - 1 through 8 (of 8 total)

Forums > MaxMSP