Forums > MaxMSP

MIDI file from Sibelius loops on its own in seq

Jun 02 2012 | 6:35 pm


A bit frustrated trying to get a MIDI file exported from Sibelius 6 to play in seq-object WITHOUT looping. There is no "bang upon completion" from the right output of seq. I’m starting to think this is some Sibelius bug. But I’m hoping someone has a work around?

A bit of a panic, too! Need to get this ready yesterday!



Jun 02 2012 | 8:29 pm

Are you sure that the exported midi file has format 0 ?

Jun 02 2012 | 10:30 pm

Yes, it’s format 0. I’m sure, because I made a format 1 first, which wouldn’t work at all…

Jun 03 2012 | 1:17 am

Have you tried playing the file with some other sequencer program?
Or you could upload the file here and we may find out what’s going on.

Jun 03 2012 | 7:13 am

Thanks broc! I’ve uploaded one file which auto-loops for some reason.

No, I haven’t tried another sequencer, really. I very seldom work with MIDI files, so I wouldn’t know what to do with it in another program either.

I’m guessing that Sibelius simply exports rather dirty MIDI…

  1. Maejejf1.midi
Jun 03 2012 | 10:09 am

For me the file plays correctly in other sequencers, but also in Max. Duration is about 2 min.

-- Pasted Max Patch, click to expand. --

Jun 03 2012 | 7:53 pm


Thanks for checking it out! What you say makes me realise that Sibelius is exporting way too much as a MIDI file! Instead of just an excerpt, which is what it is supposed to do… Well, my fault! Thanks a lot, you did straightened me out as to what was wrong: faulty human operator!! (As so often…)


Viewing 7 posts - 1 through 7 (of 7 total)

Forums > MaxMSP