Forums > MaxMSP

MIDI not working

Oct 15 2010 | 12:26 am

Max veteran here, but really pulling my hair out on this ridiculous problem…

Can’t get any MIDI output from Max. Nothing from MIDITester, a simple patch, etc. Can play MIDI files through Quicktime, and have MIDI output from Sibelius, Finale, and Logic. Any ideas as to what I might be missing? On a Macbook Pro, and always selecting AU DLS Synth as my output device.


Oct 15 2010 | 4:28 am

There are known issues with Snow Leopard and earlier versions of max 5.1.x. Are you running the latest MAx5.1 update? For more info do a search on AU DLS and Snow Leopard on this board. Otherwise it’s a mystery…

Oct 15 2010 | 7:44 am

Wow–I’m normally much better about poking around previous threads before asking, as I clearly should have done here. That fixed it. Sorry to take up your time, spectro.


Oct 15 2010 | 7:45 am

And, by "that fixed it", I meant upgrading to Max 5.1.5.

Oct 15 2010 | 9:03 am

Hah !
Oddly enough, i’m running Max 5.1.5, and maxosXtiger 10.4, and it’s precisely since the latest upgrade that it doesn’t work anymore. What precisely doesn’t work is , when i create a msp object with dsp off, it immediately sends note off to any playing midi note, and the au dls synth crashes, meaning that i can’t use it to emit a single midi note after having creating that msp object. Ill try reinstalling max 5.1.5, then 5.1.4 ; but maybe correcting that bug for SnowLeopard made it reappear for older os…

Oct 15 2010 | 9:16 am

isn’t it possible to download older versions of maxmsp ?
edit : i could download 5.0.8 after just a little query
edit again : it seems i can’t install that older version. The installer sets action on "ignore" by default, and i can’t change that.

i’m in deep need of help now.

Oct 19 2010 | 12:03 pm

problem solved by trashing max preferences. seems that changing the I/O vector size would suffice.

Viewing 7 posts - 1 through 7 (of 7 total)

Forums > MaxMSP