Forums > MaxMSP

Midi slow down when using Mac Mini Headless (without monitor)

Oct 30 2012 | 6:11 am

We are using a Mac Mini ( new with 10.7x) taking signals from a Miditron board which then controls a large motor via a Cyber Pak Midi/DMX dimmer pack and a MOTU Fastlane midi interface. This is for a student gallery installation. Everything works great as long as the monitor is attached (doesn’t even have to be powered on, just attached), but once the monitor is unplugged or not attached during start up, the midi starts to malfunction. I have found a couple of other mentions of Headless Mac Mini issues, but solutions don’t seem obvious. At the moment, we have stuffed a disassembled flat screen into the security case, but this isn’t a real solution. Any help would be greatly appreciated. Thanks.


Oct 30 2012 | 7:49 am

In a similar situation (but with OSC over udp) the solution was to remove an itable object in the top-level patch. Maybe other UI objects have similar issues.

Feb 14 2016 | 12:53 pm

Just ran across this. $15 on Amazon, promises to resolve that issue. Might work?

Feb 14 2016 | 3:54 pm

Ooooh, interesting. I’m planning to use a headless Mac mini so I’d probably end up with this same problem. Thanks for bringing it to my attention!

It seems that if there’s no monitor plugged in the GPU is turned off, and this slows certain things down. There’s apparently no software solution, so that $15 gizmo (or similar) is the only fix.

Feb 15 2016 | 7:55 am

I had this same issue with a DMX controller getting information via a serial out. Glad to find out what the issue was!

Viewing 5 posts - 1 through 5 (of 5 total)

Forums > MaxMSP