Forums > MIRA

Mira connection error

Oct 21 2013 | 1:55 pm

With the new version of mira (and Max 6.1.4) I’m getting a "Server Error" Error 61, The Operation couldn’t be completed. Connection refused… on my iPad (iOS7).

Ans help or suggestions?

Oct 21 2013 | 3:57 pm


I have exactly the same problem since the Mira update.

Until now I was able to connect the iPad through both my home internet wifi or a local network started from my laptop. Everything was fine, except the slowness with my internet connection of course. None of these solutions is working anymore…

I’m using Max 6.1.4 on OS 10.7.5 (MacBook Pro).

The error doesn’t affect Max itself (like it was mentioned on another topic), it only forbids me to connect from the iPad.

Thanks for your help.


Oct 21 2013 | 4:39 pm

Are you able to dismiss the error?

If you quit mira and restart it – are you still unable to connect?

( Quit as in hit the home button on the ipad )

Please let us know



EDIT: If you quit the app completely, as in double tap the home button and either x-out or swipe away the app, does that make any difference?

Oct 21 2013 | 6:35 pm

Yes absolutely, I tried to quit and relaunch Mira a few times (single hit on home button, then double tap/swiping etc.), and even restarted the iPad, the result is the same.

Oh, I forgot to mention I’m using iOS7 too…

I attach a screenshot of the error. "JV-Network" is my internet wifi, but as I said the result is the same with my local network.


  1. photo


Oct 21 2013 | 10:32 pm

I just updated to Max 6 and purchased Mira today and I’m getting the exact same error. I’m on iOS 7 and Mac OS 10.8.5. I tried restarting Max and rebooting my iPad to no avail.

Oct 22 2013 | 2:09 am

Same error with IOS 7 and Mac OS 10.6.8 but only with computer-to-computer network.Evyrything is correct with home internet wifi.

Oct 22 2013 | 2:35 am

Tried everything what came to my mind, restarted Mira (swiped in the multitasking screen), restarted Mac, restarted iPad. Even tried with deactivated firewall on my Mac.
No luck.

Mira worked flawlessly (ok, with the known bugs) before the update.

Oct 22 2013 | 4:31 am

Hey all,

Really sorry that the update seems to have caused this new problem to emerge. I’m working on a fix as we speak.

Just to confirm, it looks like everyone is on iOS 7, is that right?

Oct 22 2013 | 5:16 am

Yes, iOS7 on iPad2.

Oct 22 2013 | 7:01 am

IOS7 and iPad2 to.

Oct 22 2013 | 9:32 am

Cool. I have some sense of what’s going on here–it looks like the iPad 2 and the desktop Mira are opening up connections on the wrong interfaces. This might be an easy fix, but it will have to wait for testing. I’ll let you know as soon as I have some more insight. Thanks again for your patience, and for sending me such thorough debugging info to work with.

Oct 22 2013 | 10:03 am

Hi Sam, thanks for your feedback.
Just for precision, I think the iPad I’m using is 4th generation (with Retina screen and Lightning connector), bought in december 2012. So maybe another problem…?

Oct 22 2013 | 10:05 am

@Julien But it is still iOS 7, right?

Oct 22 2013 | 4:48 pm

Yes it is ! =)

Oct 22 2013 | 8:55 pm

Okay, one more thing to try. Is everyone using the latest Mira package? You actually have to download the package again and update the mira.frame object from 1.0.7 to 1.1.4. Apologies if this wasn’t clear. Hopefully this fixes the problem!

Oct 23 2013 | 1:59 am

Sorry, if I wasn’t clear, but yes, I’ve installed the new package first before updating the app.

Oct 23 2013 | 2:26 am

Same for me. Just in case I re-installed it like 2 times, first erasing the previous one, then copying again…
The help file of mira.frame mentions the umenu, so it should be the good one.
I’ll try it again tonight, I don’t have my iPad with me right now.

Oct 23 2013 | 2:39 am

The new package was installed… Sorry !

Oct 23 2013 | 5:15 am

@dolce No no, that’s okay, it just means the bug is more interesting :)
Thanks everyone for your patience! I’m still trying to work this one out.

Oct 23 2013 | 1:46 pm

Running iOS7 and MacOS 10.8.5.

Experienced same Error 61 as others.

Found kludge: remove WiFi in Network Prefs.

Connects, no problem. Maybe this will help you find
a permanent solution.

Oct 23 2013 | 2:22 pm

Thanks Wells. Which Network Preferences do you mean? Mac or iPad?

Edit : So I tried to change the Prefs on the Mac, created a new config, even reinstalled Mira on the iPad, nothing changed.

Maybe a clue : when I did my new network config, I created a local network with another name, just for trying (let’s say AdHawk instead of Jv-Macbook).
Strangely, when I tried to connect from Mira, the name displayed for the local network was the previous one, Jv-Macbook. I mean in Mira, not in iPad settings, where AdHawk is shown properly. Is this normal?

Oct 23 2013 | 2:57 pm

Hey Sam – I’m on 6.1.3 and I get the same Error 61.

Can’t remember seeing it before

EDIT By the way I mean IOS 6.1.3. Although just checked and Max is 6.1.3 too. I’ll upgrade that and see if there is any change…..Nope same thing with Max 6.1.4

Oct 23 2013 | 3:12 pm

Mac Network Prefs.

I reinstalled WiFi after posting, and it still works.

Oct 24 2013 | 1:56 am

FWIW, MBP 2×2,4 10.8.4 iOS 5 max 6.14 mira package 1.1.4 and latest iApp, no crash, but live.grid is unresponsive (may have read somewhere that I should upgrade to iOS 7 for it to work, but then Mira would crash… My choice is made for now…).

Oct 24 2013 | 5:39 am

I tried Max 6.1.4 with the new package and the Mira update on 10.8.5 with iOS6 on an iPad 3. It worked as it used to (a bit clunky) and the umenu showed on the iPad, but would not populate or let me change its drop-down.
Reading this, it looked like Sam was very keen on iOS7, so I updated to that having resisted for ages. Now Mira will not launch at all. I am not getting an error number, just ‘submit report’, and iOS7 is looking pretty ugly to me…

MBPr 2×2.7

Oct 25 2013 | 12:38 pm

If you are having connection problems and you would be willing to help us solve them I can get people access to beta versions. Please email support and we’ll get you going.



Oct 26 2013 | 4:00 am

I switched yesterday to OSX 10.9 (from 10.7.5) and guess what… no more error.

Oct 26 2013 | 7:10 am

10.9 might be better than 10.7 for this, but DO NOT do this upgrade yet if you use PT…

Oct 30 2013 | 1:39 am

Something new. I changed location with not the same provider and less people connected around me. Now Mira look fine. I connect it at the same ad-Hoc network as before. All is the same execpt location.

Oct 30 2013 | 3:42 am

Hi dear,
Could you please check it at friend computer? or please delete all and re-install it.


Oct 30 2013 | 3:47 am

Installed the new package first before updating the app.
Linksys Router Tech Support

Nov 03 2013 | 9:38 am

Eureka ! Error 61 is coming only if my laptop is also connected to network with ethernet cable.If I disconnect the cable Mira is working correctly.Is the same thing for all of you ?

Nov 03 2013 | 10:51 am


Nov 03 2013 | 1:03 pm

No ethernet cable for me in any case… :(

Nov 04 2013 | 6:14 pm

I can confirm with 10.9 and iOS 7.0.3 the problem is resolved by removing wired connection. Only problem is I really do need my ethernet connection and would rather have my wifi off.

Nov 07 2013 | 10:40 am

Have not been able to connect with my MIRA app since purchase. I tried adhoc network from OSX 10.7.5 and 10.9 on two different machines. I am running Max 6.1.5 and Mira tools 1.1.4. Is there something basic that I am missing? Getting this error every time:

Server Error:
Error 70007
POSIX error 70007

Any guidance would be helpful – the application is completely useless to me currently.

Nov 07 2013 | 10:46 am

@jmcjedi Really sorry you’re having so much trouble. Hang tight for a few days, there’s an update in review that should address exactly your issue.

Nov 11 2013 | 1:12 pm

Hey all,

If you’re still having this connection error, try version 1.1.6. See if that doesn’t help.

Nov 11 2013 | 8:06 pm

Unfortunately, I am still getting the same error (as seen in the attached image). Mira 1.1.6, Max 6.1.5, iOS 7 (on an iPad 2), OSX 10.7.5. The machines see each other, but just will not connect. I have restarted each machine, reset network settings and reinstalled both the app and the corresponding max software. I have tried both a non-firewalled local network and an Ad-Hoc network.

Are there any tricks to try to get this to work? Is it solely an iPad 2 problem? Any help would be appreciated.

Has anyone made changes to either their primary machines or on the iPad that have been helpful in a similar situation?

  1. photo


Nov 12 2013 | 12:49 am

Hi Sam,
Everything is allright now for me.

Nov 12 2013 | 4:47 am

@dolce Great to hear.
@jmcjedi Huh. I’m really sorry you’re still having trouble. Of the top of my head, all I can think of is that the network error you’re experiencing is exactly what I get when my MacBook firewall blocks the Mira connection. Are you sure that you don’t have some kind of network configuration blocking incoming connections?

Nov 12 2013 | 10:26 am

That was what I was thinking, but I tried a separate machine and got the same thing. I will do some more exploration. I was able to get Mira to work well with my Windows machine, so a solution has been found that will tide me over. I will check back in with an update after further exploration.


Nov 12 2013 | 10:34 am

did you tried to repair permissions?

Nov 12 2013 | 11:19 am

What would be a super useful thing for us would be to collect lists of running processes from people who are experiencing the error. You can get this from Activity Monitor. I’ve like to compare these running process lists ad see if we can’t find something in common with them all.

If you are stuck with the 70007 error please feel free to get in touch with support, and we can try and get to the bottom of it.



Nov 12 2013 | 1:42 pm

I am not even sure what you mean by ‘repair’ permissions? I will look into it, thanks for the reference.

Nov 15 2013 | 8:55 am

So I just installed the newest Mira on my Mac Book Pro 10.8.5. My iPad is is a little old. It is running iOS 5. But, I am getting the same error 61. Thoughts?

Nov 15 2013 | 8:58 am

@laertesweisman Really sorry about that. By any chance, is your macbook connected to ethernet by a physical cable?

Nov 15 2013 | 9:00 am

It is not. I actually took it off the network. It is only connected with the ad hoc.

Nov 15 2013 | 9:06 am

If you running Mira 1.1.6, then I really can’t say what’s going on. I’ll let you know as soon as I know what’s going on. In the mean time, restarting your iPad may help.

If you get the chance, could you tell me if you have any luck with another computer?

Nov 15 2013 | 9:21 am

I’ll try on another computer. I have restarted the iPad and computer a few times.

I’ll let you know if I have luck on another computer.

Nov 15 2013 | 10:47 am

I made a new patcher and it works. Thank you

Nov 22 2013 | 9:09 am

Mira 1.1.6 fixed the problems for me – thanks so much!

Nov 28 2013 | 6:55 am

Apologies if this has been solved for most folks, but I’ve just downloaded Mira today and am having problems. Basically it worked once, but hasn’t worked properly since my first attempt. Here goes:

iOS 7.0.4
OS 10.8.5
Mira App v1.1.6
Max package v1.1.6
Max 6.1.5

1. Connected once on my home wi-fi network, all fine and dandy, lovely.

2. ‘closed’ Mira by pressing home button, back to home screen on iPad, patch still open in Max.
3. Reentered Mira, patch no longer displayed, but now showing Mira connection page (i.e. the one with ‘Current WiFi’ and ‘Ad Hoc setup’). Since then, it doesn’t work: reopening the patch in Max, creating new mira.frame, or anything, does not reconnect Mira.

4. I tried: quit Mira completely; uninstalled/reinstalled App; uninstalled/reinstalled Max package; restarted iPad and computer.

5. Created a new ad hoc network. App appears to reconnect with the mac: under ‘Max Servers’ the app reports the name of the mac, but after a few seconds gives a yellow warning triangle and a ‘Disconnect’ button. If I press Disconnect, it becomes a ‘Connect’ button, and if I then press that, the App finally connects and THEN I can see my patch in the App and it seems to work ok. Now, I can ‘quit’ the app, reenter it, and it still works so long as I have my ad hoc network running. If I swipe-close the App, restarting it now gives ‘Mira unexpectedly quit, would you like to send an anonymous report’ etc. But I can then press the ‘Connect’ button and it reconnects to my ad hoc network and it works ok.

6. But it no longer will connect over my home wi-fi network at all, even though it did one time. Wi-fi network otherwise fine.

Anyone shed any light here? Sorry if I missed something obvious.

Nov 28 2013 | 9:13 am

btw i don’t have any ethernet cable connected.

Nov 29 2013 | 6:45 am

@incky Wow, really sorry to hear you’re having so much trouble. Are you getting a connection error when you try to connect Mira over your WiFi network, or is the Max app not even showing up?

Dec 02 2013 | 5:02 am

Hi Sam et al.,

I’ve having approximately the same problem than Incky :

• When using a non ad-hoc network (i.e. a network created on my Mac Mini for sharing an ethernet-fed internet connection):
– It works the first time I open Mira on my iPad: automagically connects and all…
– if I ever close the app or move to another app, then I have the Current Wifi / Max servers window, and no visible server – sometimes that also happens when putting the iPad in sleep mode, and reopening it (directly on Mira)
– sometimes also, without going away, the Mira interface just unexpectly disappears, and I’m back to the good ol’ desperately empty Max servers window
– from then on, the only way to get Mira back to work (it must be French: always on strike !) is to restart the iPad

• I have tried to create an ad-hoc network, but then:
– either I get a POSIX error (I have forgotten the number, maybe 5000-ish) when trying to connect
– either it works for some time, and does soemthing very near to the previous situation

Max 6.1.5
Mira 1.1.6 package and app
MacOS 10.8.5
Mac Mini i7 2.3GHz

anything else you’d need from me ?



Dec 03 2013 | 3:48 am

Hi again,

Ok having been away for the weekend I decided to try again!

This is weird:

On opening the Mira app over my home wi-fi network again, the app connects to the wi-fi network fine and it shows my iMac as a server.

In Max, as soon as I create a mira.frame object, the app gives me a popup:

"could not connect to server: [my servername]

Error 70007, the operation couldn’t be completed. (POSIX error 70007 – unknown error: 70007)"

This popup I can simply ‘okay’ and it goes away, and then my iMac is listed under Max Servers in the app, with a Connect button. I hit Connect, and after that everything seems ok – I can destroy mira.frames and create them at will, and the app behaves fine.

I can also quit the app, and quit Max, independently, and restart both and they seem to be ok – except that the app says it quit unexpectedly, and do I want to send an error report. But it actually behaves ok now.

So somehow it seems to be working at the moment, despite the POSIX error.

But it would be nice to know it will be a bit more robust on other networks (I have to try it next week on another network and am hoping to use this for a performance next year…)

Dec 03 2013 | 3:58 am

For me too, it asks for sending a Report even if it didn’t crash

in case that helps…

Dec 05 2013 | 9:37 am

I’ve found it’s worth fiddling with network settings a bit, esp DHCP if you have ethernet things plugged in.

I still don’t quite understand DHCP and networking and all that nonsense, but I did manage to get Mira controlling an Arduino connected via ethernet:

Mira 1.1.6
iPad 1, ios 5.whatever
MacPro 10.8.5

Anyway looking forward to playing more.

Feb 05 2014 | 12:22 am

…same problem in my new mira! install :(…error 70007
ipad mini ios 7.0.4.
adhoc or home network…repeat error 70007

Apr 28 2014 | 3:23 pm

I posted it elsewhere but it seems to belong on this thread….

I have been using Mira for about a week now with great results but ran into something this morning. I was using it on my in-house wireless network via an Apple Airport that leads out to the internet. I will eventually be performing in a space where I don’t want to use their public WiFi. I created a network on my laptop. My iPad sees it when I identify it in Systems Preferences and connects but Mira doesn’t see it. First questio is, can it be done this way? Second, what might I be missing? Third, is there a tutorial document about this?

I have…

Mira 1.1.6
iPad Air, ios 7.
Max 6.1.6
OSX 10.8.5
MacPro 10.8.5

Apr 28 2014 | 6:24 pm

Reading INCKY above I pressed OK and was able to connect from IPad to my computer-to-computer network.

Another wonderment…if Mira sees two computers each running max with mira frames it brings both up on the iPad. Not sure how i could use that but perhaps switch frames in some context would be useful.

Apr 28 2014 | 7:15 pm
May 17 2014 | 11:43 am

I encoutered the same 70007 error today while building a new Windows 8 system. This system is WIRED to the network. No wifi for now.
The problem vanished when I gave sufficient access permissions in the firewall to MAX and Bonjour. Sufficient, in this case, means: wide-open for private and public nets :-)


Jun 06 2014 | 3:36 am


Is this a Max + Mira bug? :

When creating ad-hoc servers, and for some reason, the servers do not connect, they seem to never be forgotten by Max, even after restarting max, mac and ipad.
So when connected to a new wifi server, Max still tries to connect with mira on the old destroyed server.

Mira says it is connected to the good server until max is launched. Then it only sees the wrong one (which should be not here anymore)
I have tried to reinstall max, but no progress

This is very problematic.

Max 6.1.7
Mira 1.1-7
iMac OS 10.8.5


Jul 04 2014 | 7:50 am

I encountered 70007 error today and I solved after hours of struggling. It has something to do with Mac firewall (pf) configuration. I am using

OSX 10.9.5
Mira 1.1.7
Ipad 2

I have Icefloor to configure pf. Although the firewall was off, it was blocking Mira. So, I started pf firewall with Icefloor, I chose no_filtering_and_no_logging preset. This solved connection error using a router or modem. To solve the same error on ad-hoc, I used following network configurations;

Manually configuring the Ad hoc network connection by manually setting the TCP/IP address, subnet, and router in the Network Preferences for the Wi-Fi settings on my MacBook Air as the subnet as the Router on my iPad as the subnet on iPad as the DNS and Gateway

Viewing 66 posts - 1 through 66 (of 66 total)

Forums > MIRA