Forums > MaxMSP

[mxj] Simple Memory Leak Troubles

Jul 12 2006 | 2:04 pm

Jul 12 2006 | 4:07 pm

On 12 Jul 2006, at 16:04, Daniel Iglesia wrote:

> It takes a list of numbers, does
> some stuff to it, and spits out a new list; yet it
> seems to allocate memory for each call and does not
> seem to ever clean it up.

Sure it does; I ran your test program, and after a while it garbage-
collected and the available memory figure dropped right down. It
collects (on my system) about once every 40 seconds.

nick rothwell — composition, systems, performance — http://

Sep 03 2006 | 8:23 pm

Hello everyone,

a couple of weeks ago I upgraded from OS 10.3.9 to OS 10.4.6 (on
Powerbook 1.33 GHz, 1 GB RAM, still working with Max/MSP 4.5.7). I
also installed the corresponding driver for my M-Audio 410 Firewire
interface. Since then it happens from time to time that the DSP
doesn’t start correctly: Although the DSP Status window shows Audio
"On" CPU Utilization stays at 0% and nothing happens. The problem is
hard to deliberately reproduce. It appears with completely different
patchers and usually disappears after restarting Max/MSP while
opening exactly the same patches and starting them in exactly the
same way. I thought, it might have to do with using Max after
awakening from sleep mode, but today (in a live-concert by the way) i
faced this problem directly after opening Max and it could not be
solved by just closing and reopening Max – I had to restart. After
that everything worked perfectly again.

Has anyone faced the same problem or does anyone have an idea about
the source of the problem? Has it to do with the OS, the driver oder
Max itself? Any solutions?

Thanks for your help!

Sep 05 2006 | 2:36 pm

Most likely you aren’t authorized for MSP, just Max. Send a note to and we can get you squared away.

Andrew B.

Sep 05 2006 | 3:18 pm

Am 05.09.2006 um 16:36 schrieb Andrew Benson:
> Most likely you aren’t authorized for MSP, just Max.

I got my authorization for Max/MSP in 2003 and have been working
quite a lot with it since then.
The problem I described never appeared before upgrading my system to
OS 10.4.6 (including upgrading to the latest audio driver for the M-
Audio 410).
Today it happened again and I tried changing the Audio driver to Core
Audio (leaving DSP on) which actually worked; switching then back to
the M-Audio driver I got again only silence (DSP status window
showing Audio "On" and CPU = 0%). After reopening Max/MSP using the M-
Audio driver everything worked fine again (absolutely the same patch,
no random functions included, not CPU intensive). So far it has
happened with a couple of different patches – therefore I don’t think
it is related to the behaviour of a particular object. I guess it
might rather be a driver problem.

Has anybody else experienced it?


Viewing 5 posts - 1 through 5 (of 5 total)

Forums > MaxMSP