Forums > MaxMSP

Noisy Patch

Mar 25 2008 | 1:38 am

I have a patch that has here to date has worked fine. Now when I run it though there is some noise (static like) coming through both sample playback and audio processing. The only thing different on the computer is that I now have a separate hard drive that I’ve put all my files on. Thinking this may be the problem I put the files on my desktop but still got the same problem.

I am also having problems with the .coll file. When I open it it says it cannot fragload adc~ (error 2807.) This doesn’t make sense given that it has worked before and the original files has the adc~. It also crashed when I try to run it.

Does anyone have any thoughts?

I am attaching the max file w/o the sound files.


Mar 25 2008 | 1:50 pm


Mar 25 2008 | 2:10 pm

(difficult for the readers of the e-mail list version to answer your
question… Concise, but maybe too much.)

> Anyone?

Mar 25 2008 | 2:18 pm

Maybe it’s only me, but I can’t open you file. It said it was a quicktime file, but that didn’t work, so I changed the extension to .mxb, but that didn’t work as well. Maybe that’s why no one has helped. Or it’s just me.

Mar 25 2008 | 3:21 pm

Mar 25 2008 | 3:35 pm

I notice too that I am getting some spikes in CPU usage. Is this related to vector Size or what?

Mar 25 2008 | 11:46 pm

It seems I enjoy replying to my own posts =)

Anyway, here is the patch attached as a text file rather pasted in if that helps anyone.

Still getting weird scratchy noises though.

Any thoughts or help would be great.


Mar 26 2008 | 1:14 pm

Quote: artmusicsouth wrote on Wed, 26 March 2008 00:46
> It seems I enjoy replying to my own posts =)

That’s one way to reach "senior" membership.-

I imported your text patch into Max. A couple of things were missing…

• error: stharms1~: No such object
• error: stgain1~: No such object
• error: fpic: can’t find file trinity.gif
• error: sfplay~: can’t find file Mvt. #1 .ms. #1.aif
• error: sfplay~: can’t find file Mvt. #1 .ms. #1.aif
• error: sfplay~: can’t find file Mvt. #1 .ms. #1.aif

The fpic is harmless. I can’t say about the rest. Also note that not everyone has altiverb~.

Your patch is complex enough and I didn’t notice anything obviously wrong with it. So your best bet is to try dismantling it chunk by chunk to localize the issue.

Also, if it sounded "right" yesterday and "wrong" today, that’s a sign that something changed in your system. Given your adc~ problem, I’d look carefully at your search path.

Mar 26 2008 | 1:27 pm

Thanks for that Peter. The objects missing are the IRCAM jimmies I think. The missing sounds files I do have and are in the search path. Those errors are not on my machine. I think I may replace the altiverb~, too.

Thanks. I am still working with it and getting noise. Could it be my vector size?

Viewing 9 posts - 1 through 9 (of 9 total)

Forums > MaxMSP