Forums > MIRA

Fixed. Not getting the new mira objects to behave (umenu, swatch, live.grid)

Oct 22 2013 | 2:57 am


I’ve just updated my mira package and mira app, but htese objects don’t work properly.

Swatch is only black and white.
umenu only shows the different content on one single line, that’s not executable.
Live.grid is unresponcive.

I have max 6.1.3 running on a mac

Oct 22 2013 | 3:26 am

Yeah…umenu is just…well, unusable.
live.grid is…just stuck : doesn’t react to touch, and doesn’t reflect manual changes. And loads with backward arrows.

On the other hand swatch is working just great here.

Oct 22 2013 | 5:01 am

Same here. Besides Max chrashes when touching boths objects on the mira-frame.

Oct 22 2013 | 5:39 am

Attached a screenshot showing the ‘not working at all way’ umenu behaves. It is not a drop down as expected but a text frame that shows you all the menu items in one string.

osx 10.7.5, max 6.1.4, ipad 4, ios7, mira 1.1

  1. IMG_0013


Oct 22 2013 | 6:58 am

Make sure you update to Max 6.1.4 for live.grid to work properly (otherwise it will display but you won’t be able to touch anything).

@fedde what does your patch look like on the mac ? For instance if you go to the "supported UI Objects" tab of mira.frame‘s help file does it show up properly?

Oct 22 2013 | 8:17 am

The patch only contains a mira.frame and a umenu. Tested in presentation and patching view. The result on the ipad in both situations is shown in the screenshot that was uploaded in my previous comment.

The "supported UI objects" tab shows up properly. But the mira.frame help file does not contain umenu nor any other new in 1.1 supported UI objects.

The UI objects that where included in the first release still seem to work. The swatch object also works fine.

Oct 22 2013 | 8:24 am

the max window shows: Mira Initialized, version: 1.0.7
I was expecting version 1.1

Oct 22 2013 | 8:35 am

@fedde Make sure you download the latest mira-package that goes with the new version of Mira.

Oct 22 2013 | 8:52 am

That clears the sky. I really thought I was downloading the new package yesterday…
Thank you.

Oct 22 2013 | 10:31 am

Ok. I screwed up the mira package installation.

Now I just need to update to Max 6.1.4 for live.grid to work.
That’s wat the max window tells me :)


Viewing 10 posts - 1 through 10 (of 10 total)

Forums > MIRA