Forums > Dev

Opening svg files


June 18, 2012 | 9:03 am

Hello everyone,

I’m trying to have my external open a svg file, and I’m following the SDK’s uitester example.
However, I noticed that even if for the most part it works, any text that might be inside the svg is not displayed correctly
I’ve attached an example of a svg which Max displays incorrectly.
Does anyone have info on the matter ?

Thanks !

Attachments:
  1. process.svg
December 28, 2014 | 4:49 am

Hi there !

I have more or less the same problem: actually no text seems to be displayed in live.menu.

My guess is that Max doesn’t accept text in svg’s… looking at the built-in Max’s svg’s, such as live.dial.svg or jit.fpsgui.svg, the text in them has been drawed using path, and not text…

I’m attaching one of the svg’s

Anyone having an hint on this ?

Best,

Pascal

December 28, 2014 | 10:26 am

would it at all be problematic to outline / vectorise the text used in the images?
this is AFAIK the general way to work with svg images.
additionally, i suppose text- and font-rendering may vary from system to system.

December 29, 2014 | 2:56 am

would it at all be problematic to outline / vectorise the text used in the images?

As the svg is generated from Max, yes, I have no idea how this could be done… (suggestions ?)

this is AFAIK the general way to work with svg images.

ah… I naively thought that having text items in the specs (and working in any other environment where I’ve tried to display them), it would work here too…

but yes, of course, there might be OS-discrepancy

Thanks for the reply

Viewing 4 posts - 1 through 4 (of 4 total)

Forums > Dev