Forums > MaxMSP

Patch behaves completely differently as an abstraction?

Dec 09 2011 | 8:43 am

I can’t tell what’s going on here. What I’m attempting to do is send opengl draw commands to FantaStick running on an iTouch so that I can display a waveform. I’m also trying to add scaling so that at a later date when I then want to reuse it I can then scale and position the waveform anywhere on the sceen. When I run this patch by itself it works exactly as expected. I get a nice crisp waveform on the scree, at the place I expect it and at the dimensions I expect it.

When I run it as a subpatch though, I get a waveform that doesn’t resemble the input in any way whatsoever and often I don’t get any output at all*. I attached a print object to the end of the pack object I use to make the draw commands and when I run it as a subpatch and by itself I’m getting totally different output from the same input. Why?

-- Pasted Max Patch, click to expand. --

*When I say no output, the print object I attached showed that I was receiving the same value out of the two scale objects, which doesn’t make any sense at all since the input to one is multiplied by -1. I’m guessing my issue has something to do with the pair of scale objects. Maybe?

Dec 11 2011 | 12:26 am

No help with this one? Anybody?

Viewing 2 posts - 1 through 2 (of 2 total)

Forums > MaxMSP