Forums > MaxMSP

phase vocoder using cartesian coords

Mar 13 2012 | 4:14 am

I’ve been going through the phase vocoder tutorial posted here:
but, I haven’t been able to get the example using complex math to work. It sounds all fluttery. The patches posted with the tutorial were making max crash for me (I’m guessing this is because I am running on windows and the patches are for mac?). Any ideas why this is happening?

  1. phasevoccar.maxpat
Mar 15 2012 | 12:58 am

Have you tried turning DSP off and back on while you have this phase vocoder example patch open? In the past, I think I’ve had some strange behavior with pfft~ subpatches that are using count~ when I load one of these patches while DSP is already on—well, I sort of remember encountering this on Max 5 (maybe Max 4), don’t know about Max 6 or quite remember for sure under what circumstance I saw these problems.

Mar 15 2012 | 2:32 am

Yeah, I’ve tried that. Am I correct about why the tutorial patches are not working for me? It seems like a silly reason since the "new from clipboard" option seems to work regardless of operating system. I’d like to try out the patches posted in the tutorial to see if I just messed something up somewhere. Haven’t been able to find anything so far.

Mar 20 2012 | 2:35 pm

Anyone else willing to try this out?

Viewing 4 posts - 1 through 4 (of 4 total)

Forums > MaxMSP