Forums > MaxMSP

polybuffer~ in standalone

Nov 24 2013 | 12:13 am

Hello everyone,

I designed a patch that uses polybuffer~ which runs fine when the patch is run from max.
When I build it as a standalone, the polybuffer~ is not found, it becomes a red-ish "bogus" object.
Why is that?
I tried including it from the "build" panel, but with no luck.
How do i solve this ?
Thank you in advance.


Nov 24 2013 | 8:45 am

Anyone had that problem before ?

Nov 25 2013 | 12:48 am

I’ve got a patch which uses polybuffer~ that I’m working on at the moment. If nobody replies I’ll try and make it into a standalone and see if I get the same thing.

You should add your system and Max spec details to posts like this, as that can make a difference – are you on the latest Max version for instance?

Nov 25 2013 | 1:04 am

Hi Mark,

I have Max 6.1.5 on a mid 2009 MacBook Pro, with OS X 10.9 Mavericks.

Nov 25 2013 | 1:57 am

I build the standalone on my Windows PC also, and polybuffer works fine. So this is a Mac problem i presume? It’s not that the object malfunctions, but is not detected, like it doesn’t exist.
But i get now error on the standalone max window "polybuffer~ not a object".

If any one has an answer i would really appreciate it!


Nov 25 2013 | 2:43 am

I don’t know if it can help but I’ve had a similar problem. And someone give me this solution:

-- Pasted Max Patch, click to expand. --


Nov 25 2013 | 3:06 am

the problem i have is not a path related one. But thanks for your reply.
And if by someone you mean "korax_ole", I am actually flattered, cause that’s me! So, I am glad you found this useful!!


Nov 25 2013 | 3:58 am

Ok, I just tried building a standalone and it’s working fine for me. I’m on Max 6.1.4 and OSX 10.7.5, so maybe it’s a bug with 6.1.5 on Mavericks. If it’s possible and helpful I could try to build your project on my machine for you. Perhaps you should get in touch with support though, it may just be a bug. Fredud – what version of max/osx are you on?

Nov 25 2013 | 4:31 am

Yes , very helpful, thanks a lot

Nov 25 2013 | 5:23 am

Thank you Mark for the offer, but it needs to be 6.1.5 on Mavericks, cause it’s going to the Mac App Store. I will contact support, and let you know!
Thank you again, for your answers!


Nov 25 2013 | 6:05 am

Ok, no worries. Let us know what the problem is for the record.

Nov 25 2013 | 8:18 am

Make sure the standalone object has the "extensions" attribute checked.* uses the* located in the Cycling ’74/extensions folder.

Nov 27 2013 | 12:13 am

Yes, the extensions are checked.

I was building an mxf of the patch, and replacing the mxf inside the .app build from a previous patch version. Both max 6.1.5. with extensions included. The polybuffer.mxo was present inside the support/extensions/polybuffer.mxo, but was not found from the replaced mxf.

Rebuilding the project/patch anew, seemed to work OK.

Viewing 13 posts - 1 through 13 (of 13 total)

Forums > MaxMSP