Forums > Jitter

potential bug in…or am I having hardware issues?

Oct 25 2012 | 4:46 am

Hello. I’ve recently run across some very strange behavior in jitter. I have a simple patch that creates a number of spheres in the pattern of a grid. I set the middle one to be red.

Now, if I connect the object to either the object or the object the middle sphere goes back to being uncolored and a different sphere turns red! As soon as I disconnect the object things go back to normal and the middle sphere becomes the red one again. I have attached images of this behavior (in case you don’t believe me) as well as the patch.

I’m running windows 7. The graphics card in my desktop machine is pretty unsophisticated. I’m using the Radeon HD 4250 on my motherboard.

I tried the same patch on my laptop (also windows 7) which uses an on-board Intel GPU and I did NOT see the same behavior. Everything worked as expected. Can anyone explain this? Do I need a new graphics card for my desktop?


-- Pasted Max Patch, click to expand. --

[attachment=206818,4586] [attachment=206818,4587]

  1. notok.jpg


Oct 25 2012 | 5:52 pm

A series of clear repro steps to follow can benefit you and those trying to assist. Without it, I don’t know what to do.

I played around with it and saw no issue on my machine. But clear repro steps might assist.

Oct 25 2012 | 6:36 pm

could it be that somehow the gridshape is drawing itself and then gl.multiple is drawing it as well? If that is what’s happening, the instance gl.multiple draws in the same place as the original gridshape will not show up and it’s entirely possible for the two to have different materials. You can post a patch with Edit > Copy Compressed so we can reproduce and provide better feedback.

Oct 26 2012 | 5:59 am

Thanks for the replies.

@Wesley I did post the compressed patch. Look right above the pictures and below my post.

@diablodale There really are no repro steps to speak of. I simply connect the object to the gridshape object (as shown in the images) and the red sphere switches places. But everything works perfectly when I open this patch on a different machine which made me wonder if it is a hardware compatibility issue.

Oct 26 2012 | 6:07 am

oh yeah :) you did!

Oct 26 2012 | 4:02 pm

I had a look on OSX and didn’t see this behavior at all. Clearly something is going on, but I can’t reproduce without having a machine with the same specs. Only thing I can think of to do is to see if you can find a newer version of your graphics card’s OpenGL driver.

Nov 04 2012 | 10:07 pm

So I got a new video card and the problem went away. Very strange. I wouldn’t have thought that hardware incompatibility issues could create this type of an error… but there you go. Thanks for the responses.

Jan 26 2014 | 6:35 pm


I never did find a solution to this problem. As I said, the problem went away when I switched from on board video to a dedicated graphics card. However I now have a standalone app that I want to distribute and some of my beta testers have seen this problem.

I would appreciate it if someone running Windows with on board video would open the test patch included in the original post and let me know if you can reproduce this bug.

And if anyone has any ideas about what could be causing this strange behavior I would be very interested in hearing your thoughts.

Jan 27 2014 | 8:17 am

did you try @automatic 0 and @auto_material 0 attributes for ?

Jan 27 2014 | 7:11 pm

To debug this issue I disconnected my video card from the power supply and switched back to using onboard graphics. Sure enough the problem came back.

I just discovered that by deleting the object all of the strange behavior goes away! Can anyone explain this? Are there system requirements for using or other openGL objects?

vichug, I tried your suggestion but it had no effect

Jan 27 2014 | 7:11 pm


Viewing 11 posts - 1 through 11 (of 11 total)

Forums > Jitter