Forums > Dev

probs compiling in xcode

Jul 27 2011 | 12:36 pm

i’m quite new in making externals for max with xcode.
i installed xcode and the sdk things correctly i think.
then i have opened an existing project to see if i can build an external object (.mxo). i’ve added all the frameworks too.
in one of the uploaded pictures you can see which files are in my projects.
but when i click build xcode creates a file with the extension .mxo but it is only 4kb big. and i can’t open it in max (as you can see it in another picture)
all the messages from xcode and max are attached as well.
i really don’t know what to do now that xcode builds up a correct mxo file.
maybe some of you know what to do.
it would be really amazing if someone could help me.
thank you very much!

[attachment=167504,2472] [attachment=167504,2473] [attachment=167504,2474]

  1. 3.png


Jul 27 2011 | 1:03 pm

The line ‘pbxcp: st: No such file or directory’ suggest that there’s some reference to something called ‘st’ somewhere in your settings. AFAIK pbxcp is an internal stuff of XCode that copies referenced files into the bundle, so for some reason it thinks that you have a file called ‘st’ which, in fact, you don’t have.

Jul 27 2011 | 2:24 pm

thanks for your reply!
but i don’t really know where i can find this file "st".
i have looked in the settings but can’t find anything.
would it help to add a picture of my settings?
thanks a lot!

Jul 27 2011 | 11:22 pm

i've choosen another way.
i created a project exactly like this post:
but i get the following errors: see picture!
the only difference is that i am using xcode 3.0
i'm trying to compile a mxo file now for 3 days but without success.
it would be amazing if somebody could help me out.
thank you!


  1. 4.png


Jul 28 2011 | 11:01 am


the post you’ve linked is from 2005. Did you try just downloading the most recent SDK and the most recent documentation (which AFAIK is included in the SDK), and just trying to compile one of the example projects that you can find in the SDK? If not, please make sure that you’re able to compile at least one of the example projects that came with the SDK (you should be able to compile these without any modification). If you succeed with that, you should copy one of the example projects and replace the example code with your own.


Jul 28 2011 | 1:55 pm

hey ádám!
i’ve downloaded sdk 5.1.7. i think this should be the latest version
but what is afaik? do i need that?
i tell you what i did for the external setup.
i copied the c74support folder into /Library/Frameworks/c74support
i also copied the folder MaxAPI.framework into /Library/Frameworks/
because for now i’m really confused where to put that stuff in.
but i think this should be the right directory.
then i have the whole sdk-5.1.7. folder on my desktop from where i’m opening the example patches. but i’m always getting a lot of errors.
for example i opened the simplemax xcodeproject. no file in the project is red marked so i think everything should be fine. but when i want to compile that i get 11 errors and 1 warning. (the errors are like the picture from my last post)
i think the problem is’nt that big but for now i don’t really know which path or which file i should change. maybe you know what to do.
thanks a lot for your help!

Jul 28 2011 | 2:54 pm

i don’t really understand the sentense with not and nothing.
but it doesn’t depend on that where the framework is located.
or what do you mean?
fact is, that xcode recognizes the maxapiframework but i still get the errors mentioned in the 4.png file some post above.

Jul 28 2011 | 11:02 pm

so the thing is that i just have to download the sdk and put the folder wherever i want?
and i don’t have to change any paths or stuff like that?
and especially the line: HEADER_SEARCH_PATHS = /Developer/Headers/FlatCarbon "$(C74SUPPORT)/max-includes" "$(C74SUPPORT)/msp-includes"
in this folder on my computer there are no header files or do i have to ignore this line.
and don’t you know what my errors mean in the file 4.png?
i’m really sorry that i’m so lame but i’m relly becoming desperate because i’m repeating this process on and on.
thanks for your help! i really really appreciate that!

Jul 29 2011 | 5:12 pm

it seems that i have just some something wrong in my paths.
i found the file "ext_obex.h" and changed a little bit in the paths.
exactly i only changed the symbol " before and after the path and then i only got 1 error left (in the picture 6.png)
i also posted a little picture of my project settings: maybe it's easier to find the mistake on that way (5.png)
thank you so much for your patience so far!

[attachment=167686,2484] [attachment=167686,2485]

  1. 6.png


Jul 30 2011 | 10:17 pm

i did what you said. downloaded the sdk again and placed it directly on the hard drive. AND…it works. i don’t receive any errors.
i just opened an example xcodeproject and built the project.
a mxo-file has been generated but it has only 4kb.
and when i include all the examples in the file path in max and want to add an object the max window says: no such object.
when i looked at the size of the thresh.mxo file fore example. this file has 41kb on my computer. but the external i built just 4kb.
so another problem but i think the success can’t be that far away.
thanks so much for your help so far!

Jul 31 2011 | 9:50 am

that’ what i already did.
when i type in the first letters in max, max gives me a preview of which objects begin with these letters so i think max can find the object but cannot load it.
as is said i think the problem is inside xcode. because the built external is only 4kb big and not for instace 41kb when i look at the thresh.mxo file in my original max folder which comes with the original max.
so maybe there is something wrong in xcode. but when i build it i get no errors
hope you know what i mean.
thank you!

Jul 31 2011 | 12:04 pm

my version of xcode is 3.0
and i’m not that used with the terminal so here is my zip file:

Jul 31 2011 | 3:30 pm

oh ok.
i found the folder where the built objects are in.
now my file is 25kb big (attached
and i have included the folder where the project is in (
when i include this folder to max file paths and want to add this object is is marked red but the max window doesn’t give me an error.

Jul 31 2011 | 3:31 pm


Jul 31 2011 | 9:09 pm

you were right! i’m sorry!
everything was working as long as i changed the name of the c file.
i should have know that this can’t be working as long as i don’t change anything in the code.
so i tried to compile an example and include it. and it is working.
everything is fine now!
THANK YOU so much for your help and your patience!
i think the main problem was the path thing with the search files. so i completely became hysterical of these small problems.
hope to meet you again in this forum for "real" problems.

Viewing 15 posts - 1 through 15 (of 15 total)

Forums > Dev