Forums > MaxMSP

Removing 'Text' from textedit output


May 27 2011 | 10:32 am

I am trying to remove the word ‘text’ from the output of a textedit object, but can’t seem to figure out how to do this!

Could anyone please help!

Thanks,
Jeremy

May 27 2011 | 10:40 am

[route text]

aa

May 27 2011 | 10:41 am

I figured it out, using ‘route text’.

– Jeremy

May 27 2011 | 10:41 am

Thanks Andrea :)

May 04 2014 | 11:03 am

what is the "text" for anyway? what object requires a prepending of "text"? seems like it’s just an annoyance.

Jun 29 2015 | 2:30 pm

I often use it as comment text to be saved with a preset. With a certain setting of your patch, type in the textedit a comment to that setting and save it together with the rest in a preset location.
The reason I am reading this post was to find out how to bang the content of a textedit box into a message. That way several messages can be saved in a dedicated preset object. Very handy to browse a preset with stored messages and bang the textedit box when showing the choosen message so that the message text goes via the route object into the right inlet of the message box.
I am sure there are enough other handy uses

Dirk

Aug 31 2016 | 3:28 pm

Sorry to necro this thread but I am having the same problem, and I can’t figure out how to manipulate [route text] to get rid of the ‘text’

Can someone provide more details? The docs say that if you match the first argument, the "rest of the message is sent out," but I still get ‘text and then my message.

Thanks!

Aug 31 2016 | 3:47 pm

Figured this out. I think I was routing the wrong output. Sorry.

Viewing 8 posts - 1 through 8 (of 8 total)

Forums > MaxMSP