Forums > MaxMSP

Rewire Max 5 audio into Logic 8

Aug 10 2009 | 11:49 am

Hi, I am trying to basically get audio from a max patch of mine into logic but am having difficulty.

I know that as the host I must open logic first, I create an aux channel and open max. I then load the patch and set the outputs in DSP status to "ad_rewire". Then I go back to logic but there is no way for me to select the aux input as the rewire from the max patch.

It seems the option to do so is completely missing. Does anyone have any ideas? Am I doing something wrong?

Aug 10 2009 | 12:04 pm

I have a help file on this on my site. It is a little out of date (I wrote it with Max 4.6 and Logic 7). Should still work though. You can find the files here:

Under Max to Logic (rewire), there is a Logic file, Max patch and text file with an explanation.

Hope it helps,

Aug 10 2009 | 12:22 pm

Thanks for the tutorial but I keep running into this problem that there is a distinct lack of any rewire mention of max/msp in logic.

I also have melodyne essential installed, that uses rewire, and in logic I can always select "RW:Melodyne_Essential" as an input. However there is no "RW:MAX/MSP" anywhere to be seen.

Aug 10 2009 | 5:54 pm

i`ve checked your tutorials too. great!

midi_maxtologic is what i`m looking for. is it possible to record midi-notes from max in logic? i am very interested in connecting multiple max midi-outs with some logic instruments + recording these notes on corresponding tracks.

Aug 10 2009 | 9:32 pm

@Tommy, will you look and see if you have these files on your system.

1) In your /Applications/Max5/Cycling ’74/ad folder, do you have files called:

2) Next look in: /Library/Application Support/Propellerhead Software/ReWire folder, do you have files called:
ReWire.bundle (version 1.7)
MaxMSP ReWire Device (this is actually an alias)

If you do not have the alias, then I think you need to check to see if you are logged in as an administrator. You can check this by going to System Preferences and clicking on "Accounts". In the list it should say "Admin" under your account (see picture below). Assuming it does not say Admin under your account name, log in to your machine under an administrator’s account then open max and set your driver to ad_rewire (under DSP Status). This should create the alias called MaxMSP ReWire Device in the Library/Application Support/Propellerhead Software/ReWire folder.


Aug 10 2009 | 9:58 pm

To record MIDI notes in logic, the notes must go to the "To Recording & Thru" object. This object is usually in the "Clicks and Ports" layer of the Environment. There are many ways to do this. TO fully understand why, search for the "To Recording & Thru" in the LOGIC manual. Also, check out the section in the LOGIC manual called "The MIDI Signal Path". Anyway…

In the "Clicks and Ports" layer of the Environment, connect the "from MaxMSP 1" MIDI output (on the Physical Input object) to a "Monitor" object. You can create this Monitor object by using the local "new" menu in the environment.

Cable the white pointy thing on the Monitor object to the keyboard labeled "Input Notes". When you do this, a second white pointy thing will be created on the Monitor object. OPTION-Click this second white pointy thing and connect it to the Instrument you want the midi notes to playback on.

Now in the Arrange page, when you select a MIDI track or Instrument track, the MIDI notes coming from "from MasMSP 1" should be recorded (assuming you press the record button in the transport).

If this does not make sense, feel free to email me at:
( a_T )
(d 0 T )

Hope it helps,

Aug 11 2009 | 9:36 am

Hi, thanks for getting back to me.

I have checked and I have everything but the alias. So in the Propellerhead Software folder the MaxMSP Rewire device is not there. Predictably the melodyne rewire device is there as that is selectable fine in logic.

I have double checked and I am most definitely signed in as the administrator so thats not the issue.

Although this topic is about logic I have the same problem trying to rewire max in pro tools, so does the lack of this alias explain why I cant select Max as a rewire audio input in either? Is there anyway I can put this alias in the folder manually?

Cheers, Tom

Aug 11 2009 | 12:35 pm

Ok, I removed the alias "MaxMSP Rewire Device" from the folder:
/Library/Application Support/Propellerhead Software/ReWire

When I next launched Max and set the driver to ad_rewire, the alias MaxMSP Rewire Device was created in the Propllerhead Software/ReWire folder.

When I closed Max5, the file "MSPReWireDevice.bundle" was created in the Propellerhead Software/ReWire folder.

It should all be automatic.

Since it appears not to be automatic on your system, go here and download ReWire version 1.7 for Mac OSX

Maybe reloading ReWire, launching Max, and setting the driver to ad_rewire will correct the problem.

Also, there is a "Using Rewire in Max/MSP" section in the Max5 documentation. That may help with setup.

Hope this helps out,

Aug 11 2009 | 2:39 pm

Hi, I just tried this with no luck but had an idea that I should see if it worked on my laptop.

I had never tried running ad_rewire on the laptop before so I first checked to see what was in the propellerhead folder… but there wasnt one. So installed ReWire 1.7 and then there was a folder. I then launched max and selected ad_rewire in DSP and it created the MaxRewire thingamabob in the folder. I then opened logic and it all worked fine.

This makes me think about why it doesnt work on my main computer. The only thing I can think of was that the rewire version I have installed was done so by my installing melodyne essential, as I had never knowingly installed rewire before. Maybe I needed to have rewire 1.7 installed before trying to use the ad_rewire driver for it all to work?

So I am going to uninstall max and rewire (if i can) then install rewire 1.7 followed by max 5. Then I will load up max and select ad_rewire and hope. I will let you know how it goes in.

Aug 11 2009 | 2:50 pm

Hi, I did what I said I was going to do and now all is well. I can only think that the version of rewire I had installed before didnt like max but who knows.

So now it works, thanks for all ur help Mitch.

Cheers, Tom

Aug 11 2009 | 4:50 pm

Glad it is working.

Aug 12 2009 | 9:47 pm

thank you for your help, mitch. it works well! i have only to route by midi channel and not by device. furthermore i have added physical input to the mixer layer and connected my devices directly to the intrument tracks – a mistake of mine.i must admit that logic is less intuitive than ableton live (relating to midi control)

Viewing 12 posts - 1 through 12 (of 12 total)

Forums > MaxMSP