Forums > MaxMSP

Selector issues!

Nov 25 2011 | 12:24 pm


I’m building a synthasizer using Max on my PC. I started with a Monosynth which worked fine with 2 ADSR’s a filter and 2 oscillators. I the moved onto a Polysynth and all was going well until it got an error message saying ‘Does not understand "float" ‘ then showing me to my selector objects? I thought something was wrong elsewhere in the patch and have looked around but cannot find the problem. I have now gone back to my original Monosynth and i’m getting the same error message. I built the monosynth from scratch again last night and it worked fine then. opened it now and the same error message is appearing! Any ideas?

Note: i tried changing the selector object too a Matrix object and the same error message came up about the Matrix.


Nov 25 2011 | 8:40 pm

don’t have a float going into the right inlet of selector~ (or to the main inlet of matrix~), it should be a signal only. (or a message which they understand)

Viewing 2 posts - 1 through 2 (of 2 total)

Forums > MaxMSP