Forums > MaxMSP

"set" in mesage by itself doesn't play with uzi and trigger objects.

March 10, 2013 | 5:41 am

If I press the "set" message in this patch, it clears the following message. However, when I try to clear the message from a trigger which also starts an uzi, it doesn't clear the list.

Also, the uzi won't let me connect the right inlet to another outlet on the trigger object except the one on the far right.

Is there some occult reason for this I don't understand?


  1. Capture.JPG
March 10, 2013 | 6:35 am

fYI, my workaround was to replace the ‘set’ message with a ‘zlclear’ message to the to the ‘zljoin’ message, which worked. However I don’t understand why the set’ message by itself didn’t work, or why there’s a limitation on ordered events for the ‘uzi’s right inlet.

March 10, 2013 | 7:02 am

Umm.. the trigger message your sending to the message "set" is a list and not a bang. Try [ t b b i ] instead of [ t b l i ]

March 10, 2013 | 1:53 pm

@Ernest the reason is that the set message only clear the content of the message box, so it doesn’t send an empty list to zl.join (there’s no such thing as an empty list anyhow, a list message without argument is just not a valid list). So you’re right, using zlclear is the best way to go.

BTW, you’re patch output something like this:
print: 1
print: 1 2
print: 1 2 3
print: 1 2 3 4
print: 1 2 3 4 5
print: 1 2 3 4 5 6
print: 1 2 3 4 5 6 7
print: 1 2 3 4 5 6 7 8
print: 1 2 3 4 5 6 7 8 9
print: 1 2 3 4 5 6 7 8 9 10
print: 1 2 3 4 5 6 7 8 9 10 11
print: 1 2 3 4 5 6 7 8 9 10 11 12

if you just want to make a list of numbers from 1 to ? you can simply do something like this:

– Pasted Max Patch, click to expand. –
March 10, 2013 | 10:26 pm

That’s intereting. I’m, still learning about lists. I didn’t realize messages weren’t triggered by lists. I kind of assumed as everything else triggeed them, lists would too :)

I tried double quotes on the word ‘set’ in a prepend message too. MAX automatically inserted an escape character instead. However, when I saved the file and reopened it, the escape sequence had disappeared. Subsequent attempts to edit the text resulted in many strange errors, until I deleted the object and put another in.

March 10, 2013 | 10:37 pm

And I blame Bill Gates for that, not Max…As I understand it, he tried to get rich when he was friends with Steve Jobs by making a little box, containing half a dozen transsitors, to generate tones that fooled the AT&T exchange into letting his customers make international calls on local tariffs. But someone apparently figured out how to do the same thing by recording the tones from the box, then sold the recording for less than they were. That got Gates so mad, he decided to reverse bskslasches on a new operating system so UNIX wouldn’t work, and no one would ever be able to steal from him again. Steve Jobs got angry at him and said he was selling absolutely nothing. Not only did he refuse to try and steal from AT&T with Gates again, but instead making hardware which no one was allowed to copy. The debate continues as to which of them was better at being bad)

March 10, 2013 | 11:47 pm

All I’m saying is that in a list is something which has two or more values, the first of those values being a number. You’ll see some objects which support smaller lists but i would keep that in mind to stay out of trouble.

March 11, 2013 | 9:14 am

Could someone explain the difference between a single-elelment list containing a number, and a number?

March 11, 2013 | 3:54 pm

Ah, there’s no such thing as a single-element list then. Sorry for being slow, I was somewhat exhausted this weekend from creating my own polyphonic voice assignment logic. The poly~ system works pretty well, but I needed something slightly more sophisticated.


March 15, 2013 | 5:14 am

On consideration after a great amount of sleep, I did realize where my confusion arises. zl objects are for list processing, and one can pass things into them which only have one element in them which are handled the same way as lists. So it’s semantically confusing to say they aren’t lists.

Viewing 10 posts - 1 through 10 (of 10 total)