Forums > MaxMSP

standalone file associations


Apr 08 2010 | 1:00 pm

Does anyone know how to totally stop standalones associating with .maxpat files etc on OSX (snow leopard)? I have tried editing plists and using the opens with-> change all command in get info (in finder) but i still have problems with this. I’m not sure if it’s just because finder is not refreshing.

cheers,

oli

Apr 08 2010 | 4:17 pm

Does the standalone end with .app? If so, it *should* open independently of MaxMSP.

Apr 08 2010 | 4:22 pm

not sure what you mean – i’m not building a collective by mistake if that’s what you’re suggesting. I am trying to stop my max patches getting opened by my standalones

oli

Apr 08 2010 | 5:52 pm

The only way, that I’m aware of, is to set again the "Open wit" + change all. You might have to do that each time you make a new standalone though, because the finder thinks that you just got a new application to open your .maxpat.

Apr 08 2010 | 6:48 pm

Sorry, I was thinking you meant your maxpat files were trying to open your standalone. My bad!

Sometimes when I’ve had stubborn "Open With" problems repairing disk permissions has helped. You might give that a shot after setting the .maxpat files to open with MaxMSP and change all. Good luck.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums > MaxMSP