Forums > Max For Live

standalone vs M4L

Jan 18 2012 | 9:49 pm

I’m trying to run a max patch standalone next to (at the same time) a live set with M4L inside it.

I discovered that the M4L devices don’t load correctly the first time I open the live set (like the buffer shuffler). For make it working, I need to manually insert a new M4L device inside the track and then it works.

Does Max standalone mess something and make the M4L devices not stable?

Jan 18 2012 | 10:30 pm

Based on your description I am not able to reproduce a problem.

If you like, send a small live set and a standalone in to support and we can check it out



Jan 19 2012 | 3:56 am

Finally, it doesn’t seem to be affected by Max standalone running.

The set is really simple: one audio track with the buffer shuffler (8 -anything Goes preset, basically a chucker~). Working well the first time I inserted it inside the track. Then, save the set and reload. The loop works for 1 or 2 loops and then, the effect doesn’t work as it’s supposed to for the loops after (the sound passes through the effect without modification except an audio clip at each beginning of the loop). If I insert a new same device, this one will work well.

In my other set, in which I noticed that problem, it’s the object play~ which doesn’t play anything even if all the audio objects around it work.

Strange thing, the problem came today while it worked before and I did nothing on my system since yesterday!

It doesn’t make sense at all for me and it drives me a bit crazy!

It seems to be specific to my system but it’s doing exactly the same thing on my both computers.
here are the specs:

Macbook pro2.8 GhzIntel Core 2 Duo 17 inch, 8 go, 10.6.8, NVIDIA GeForce 9400M, Live 8.2.7, Max 6.0.2
Hackintosh (Desktop HP Pavillon) 2.33 GHz Quad-Core Intel Xeon, 8 go, 10.6.5, GeForce GT220, Live 8.2.7, Max 6.0.3


Jan 19 2012 | 5:29 am

ok, I solved the problem of the first patch (the one involving play~) but not the second one (involving chucker~ inside buffer shuffler)

I used play~ inside a poly~ but the buffer referred to was in another M4L device on the master track. For some reason, I started to get the error messages in the max window when opening the set: "play~ | no buffer~ main". Even if it was the right buffer when I double-clicked on the play~ objects, it was not set to it. I guess, Live changed the initialization order of the devices and the one containing the buffer~ was probably initialized after the one containing the play~ objects.

I solved the problem by putting the buffer~ inside the same device as the play~ objects.

But, still don’t understand the second problem with the buffer shuffler.

Viewing 4 posts - 1 through 4 (of 4 total)

Forums > Max For Live