Forums > MaxMSP

Standalone won't work on separate computer

Jul 08 2011 | 4:42 pm

I’m having a problem getting a standalone application to work on a friend’s computer. When the application tries to load, I just get the error message that the application quit while unresponsive. It works fine on my computer, and I tried it on another computer that also has Max on it. I thought maybe the problem was that the other computer didn’t have Max on it, so I downloaded Max, installed it, and then got the same error message when I tried to open Max. All of the computers are Intel Macs. Has anyone had similar problems where they can’t get Max to start on their computers, or can’t get standalones to work? Any help would be appreciated.

Jul 08 2011 | 8:23 pm

i had huge issues with a standalone just today – but managed to fix the problem.

do you have the standalone object in your patch?

i was having rewire issues – but got that fixed.

maybe post the patch here, and i can try, i am on a intel mac as well.

Jul 10 2011 | 8:12 pm

If you could help that would be great. I have a feeling, though, that the problem is with my friend’s computer, and not the patch, as it worked on another friend’s computer just fine. I do have the standalone object in the patch, and I changed some of the parameters in the inspector to if that helped, but no luck. I’ve sent the patch with this reply, so if you have a minute, go ahead and take a look at it. Thanks in advance for any help!

  1. Fader142.maxpat
Jul 10 2011 | 8:59 pm


ok i downloaded that.

from what i gather its a fader/volume controller for a bluetooth device right?

i havent spent much time looking at it – but thats what it looks like.

ok – i built the application here on my computer – and the standalone opens up perfectly on my computer – no issues at all.

although it doesn’t open up in presentation mode…….

"open the Patcher Inspector by right-clicking the patch background, then check the box marked "Open in Presentation"." – gotta love these forums!

i will check tomorrow whether it opens up on my old laptop (osx 10.4.11, 800 mhz processer, 640mb RAM IBook) – if it opens up on that too (about the same power as tablets and some phones, my how things have changed!) then you know the issue isn’t with the patch)

hoep thats ok?

Jul 11 2011 | 4:04 am

I thought I had set it to open in presentation. Guess not. Thanks so much for checking this out for me!

Viewing 5 posts - 1 through 5 (of 5 total)

Forums > MaxMSP