Forums > MaxMSP

super slow maxmsp

Aug 09 2013 | 6:52 am

Hello everybody!
It has been now some time that my MaxMSP is super slow.
I bought a new macbook Pro Retina Display last summer and whenever I put some simple things like splays playing fast or one vst, the computer/processing becomes super slow and it seems the buffer does not manage this. It has happen that I turn off the sfplay~ and the audio keeps playing and stops after some seconds. The previous MacBook I had could do much more (and I mean, a lot more) processing handling… Everything is updated so I don’t understand this issue. It is annoying.

Anyone has the same problem? Is it due to retina computers cpu stuff or could it be because I am running Mountain Lion?
Any advice will be appreciated.

Thanks in advance and good luck.

Aug 09 2013 | 11:21 am

If it’s not the retina rendering cost affecting your performance. Often times, audio preferences either being manually or corrupted somehow in machine migration to have a low signal vector size is an issue. Check your Options -> Audio Status -> Signal Vector Size, and make sure that it is something reasonable like 32 or higher. If this value is set to something low like 16 or less, CPU can be expensive as the overhead for per vector operations begins to outweigh the sample operations that happen within processing a single signal vector of audio.

If neither of these seem to be the issue for you, please contact support.

Aug 10 2013 | 4:08 am

Thanks for your comments!
I had already change the signal vector size to high values such as 1024 and I was having the same problem.
For instance: playing sfplay~ + seek $1 with random values triggered from a metro = 10 ms, seems to clog the buffer. If I change the metro it will take some time for to 1) update the value in the number box controlling metro, it keeps stuck for some time 2) the audio takes seconds to update to the new values. The patch is just this… there no more msp processes or objects…

I will do more tests.


Apr 17 2014 | 3:33 am

Did you solve this?
I am having maybe similar slowness issues, that disappear when I turn of Audio DSP processing.

Apr 27 2014 | 4:21 am

Same issue here. Max is very slow in retina display mode.
Opening max in low resolution make it faster… But the same patch is much faster on my old 13 inch 2 core…
Please, Cycling, take a look at this problem!
Philippe Ollivier

Apr 27 2014 | 5:02 am


Nov 03 2014 | 10:08 am

turned low resolution mode on, vector size 32, still my 2011 macbook pro is much faster than my 2014 one….

Nov 03 2014 | 10:14 am

Here is a solution you might also want to try,
IN case you have many UI elements that you update very fast,
then one solution is to limit the number of UI events processing, which slows down the UI refresh, but keeps everything else running smoothly.
To do this in Max preferences, under the Scheduler section, set the "Redraw queue throttle" to a low value (1-10).

Apr 23 2015 | 8:47 am

I have the same problem and "Open in low resolution" helps (even if the program runs better on a non-retina screen). One thing very strange is that the problem only occurs in presentation mode! Is the patching mode automatically in low resolution??

Apr 23 2015 | 4:20 pm

same here with the super slow problem, macbook pro 2014, 15", does 7.0.3 suppose to solve the super slow problem? thanks.

Viewing 10 posts - 1 through 10 (of 10 total)

Forums > MaxMSP