Forums > MaxMSP

Techno~ Crashing

Sep 08 2011 | 6:58 pm


I’m running a brand new MacBook Pro 2 GHz Intel i7 (4 GB 1333 MHz) with OSX 10.7.1 Lion.

I made this patch which drives a techno~ object and uses a lot of list processing to add semi-random ornamentation to preset melodies. The patch repeatedly crashes Max, even without DSP running. I don’t get a stack overflow message or anything. Even trying to Copy Compressed to share with you folks crashes Max, so I’ve attached the .maxpat file.

Opening with Command+Shift crashes Max, too.

This patch seems fairly straightforward. My only concern is that some sort of loop is being created between the techno~ objects and the list-processing subpatches.

Thanks in advance for your help.

  1. technohelp.maxpat
Sep 08 2011 | 8:11 pm

I tried this – Max 5.1.8/Vista 32 – and was able to vary the melody and tempo; but the [>~ -0.5] object wasn’t triggering a bang. I manually triggered the [bang] and my debug window instantly filled up with the following: "techno – bad index"

then the patch continued to play the same repetitive melody.

I tried to change the [>~ -0.5] to [>~ 0.5] and *BANG* it crashed.



Sep 08 2011 | 8:29 pm


When you got the "bad index" message, did you set the length of the techno~ with the "Beats" and "Subdivision" variables?

Sep 08 2011 | 8:39 pm

No, they were set at the loadbang defaults; it occurred only when i clicked the [bang] object below the [techno~] right outlet

Sep 20 2011 | 5:45 pm

crashes here also, and i got the bad index message after playing with the subdivision / beats variable.

also in the in the techno~ helpfile, the "noterange" message for the techno JS UI doesn’t seem to work???

There is definitely something not right with this at the moment…

Viewing 5 posts - 1 through 5 (of 5 total)

Forums > MaxMSP