Forums > MaxMSP

transport object – problem/error?

Jan 08 2011 | 7:03 pm

I have this patch:

-- Pasted Max Patch, click to expand. --

I open this patch, use the toggle start the transport and let it tick for a couple of seconds. Then, I close it, without closing Max (leaving the Max window open), and then I re-open the patch. I click the "0."-button to rewind, but it doesn’t start from measure 1 beat 1! And whatever I do, I can’t make it start on the first beat. What is wrong here?

Jan 09 2011 | 5:48 pm

The transport help says that a timesig message can be sent only if the actual time is 0. But since you are using loadmess this may not be the case when re-opening the patch.

Jan 09 2011 | 6:09 pm

Did you leave the transport running when you closed the window? Closing a window that contains a transport object does not automatically stop the transport. So if the transport is already running when you (re)open a window, it will be at some nonzero location, and even if you reset it to 0 ticks, it will still be running, so then by the time you start banging it with a metro (which in your patch requires a separate mouse click and thus takes some amount of time) it will no longer be at 0. So you might want to check and see if that’s what’s going on.

Jan 12 2011 | 12:27 am

Yes, the transport was left open. But the nonzero location the transport starts at after the patch is reopened – it doesn’t make sense! I tried leaving the "GlobalTransport" open all the time, and let the patch go for 5 measures or so, then I reopened the patch when the global transport was at 10 measures. The transport started at measure 3.

The problem is that if you forget to stop the transport before closing the patch (since most often, you don’t worry about doing anything in a patch before closing it), and as you forget it, the error will always be present there until Max is restarted.

I "solved" the problem using a closebang object which turns off the transport and sends it to location 0 before the patch is closed:

-- Pasted Max Patch, click to expand. --

Viewing 4 posts - 1 through 4 (of 4 total)

Forums > MaxMSP