Forums > MaxMSP

Tremelo trouble with audio


Nov 29 2010 | 11:16 am

Hey guys!,

I’m making a patch to play my guitar through and everything seems to be working (kind of) so far. I’m trying to implement a tremelo object though and having no success.

Heres what I’ve got so far –

Audio Signal in – Splits to two mini patches (one clean and one OD) – SWITCH (to choose channel – Stereo Delay – Reverb – CompressorGateLimiter – Master Fader

I want to put the tremelo in just after the switch. I’ve tried creating a cycle~ object and a number~ but when I hook them up I can’t here anything. My master metres display signal going out but nothing can be herd.

If anybody could enlighten me on how I might be able to get it working I would be extremely grateful!. I’m abit of a noob so go easy ! :)

Many thanks,

Caatalyst

Nov 29 2010 | 11:30 am

post your patch: in Edit mode select all and go Copy Compressed, then paste it here. What version of Max are you on?

Nov 29 2010 | 11:33 am

-- Pasted Max Patch, click to expand. --

Nov 29 2010 | 11:45 am

Hi,

Are you using the MSP object [number~] where perhaps you should be using the Max object [number]? Here’s an example:

— Pasted Max Patch, click to expand. —

-Eric

Nov 29 2010 | 11:52 am

how do I open that ?

Nov 29 2010 | 12:16 pm

I keep trying to copy and paste that information into different windows but it doesnt open anything :(

Nov 29 2010 | 12:48 pm

stupid me, I’ve opened it but unfortunately had no sucess getting it to work with my patch :(

Nov 29 2010 | 2:02 pm

you hooked up a cycle object but you dont hear anything? thats bad.

Nov 29 2010 | 7:59 pm

Did you run you audio into the first inlet of the [*~] object and out the outlet? If so, and it’s still not working, I would have no idea what the problem is. What I posted is the same way it’s done in the MSP tutorial 8: Tremelo and Ring Modulation. Perhaps you could take a look at that (if you haven’t already) and make sure it works in the tutorial patch on your computer, and if so you could copy it from there?

best,
Eric

Nov 29 2010 | 8:23 pm

signal to be "tremoloed" goes in one inlet of the *~, a cycle~ with your tremolo frequency goes in the other. you might need to scale the cycle~ input to a better level, run it through a gainfader~ before hitting the *~. very straightforward to implement this.

Nov 30 2010 | 4:10 am

You might find MSP Tutorials 8 and 9 to be helpful, especially 9.

Viewing 11 posts - 1 through 11 (of 11 total)

Forums > MaxMSP