Forums > MaxMSP

Updated OS to 10.6.4, now Max patches are messed up

Sep 17 2010 | 2:41 am

As the title says, I recently updated my OS on my MacBook Pro to 10.6.4. Max is updated to 5.1.5.
Now, when I attempt to open any Max patches, here's what happens—when I try to open any Max patch, Max opens seemingly whatever Max-generated App it can find first, then the patch I was attempting to open, opens as if it is an App, i.e., not ability to unlock, etc., with the aforementioned App in the background. For example, it kept doing this opening an App I had saved of my own–so I went through and hid any Apps I had made myself in the Trash. Tried it again, and it opened up the "Endless" app by Gleetchplug! I forgot I even had that thing on the machine! Also, in the "patch" (I say that loosely now as they are all screwed and open as apps . .or, something . . .) various things are grey'd out, like sliders, video windows, etc. Also, none of the files/patches/apps–whatever the hell they are now can be closed, brought to the foreground, etc. except for the "Endless" app window, but even that can't be closed–or modified–I just have to quit Max.
I threw out "Endless" and tied again and Max found one of my own apps in the trash and opened that first!
I have attached a couple screenshots to hopefully show this bizarre phenomenon. I re-installed Max 5.1.5, and the problem persists. Even Max patches I didn't create are screwed–see my attached screenshot #3–I try to open the "cheby" example, and Max opens an app I had made called "Elements_Oct" and the Cheby pops up in front, but not as an editable patch, and the "multislider" is grey'd out.
Holy cow, I'm freaking out–nothing I have built over the last 2 years can be opened now! I quickly made a new patch and just slapped some objects in it. Same problem!
I pray someone can help me–I am sending an email to support as well.
Many Thanks.

[attachment=141768,1142] [attachment=141768,1143]

  1. Max_problem_ex3.jpg


Sep 17 2010 | 11:49 am


select a .maxpat file ; press cmd+i ; select maxMSP in the "open with" part ; clic on "change all…"

Sep 17 2010 | 2:04 pm

Interesting, thanks. That does work. In the meantime, last night, I had gone through and removed every instance of a Max app, copied them to an external drive, and trashed them(and disconnected the drive) and only then it worked properly. Now I put everything back where it was, and did your suggestion, and it seems OK now. (However, I went straight to your suggestion, therefore skipping completely re-creating the way it was). The crazy thing(to me at least) was how it plucked one of these apps out of the trash to open first. But it is working now–many thanks.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums > MaxMSP