Forums > Jitter

USB Cam not available through jit.qt.grab

Nov 06 2007 | 7:35 pm


I’ve bought these crappy usb webcams (Generic ZC0301P Webcam #0
) to experiment with, but I have some trouble to grab video in Jitter.

– I’ve downloaded Maccam, and the videosignals are available in both Quicktime and HackTV … but not in Max MSP Jitter.

Firewire cams and DV cam works fine, but not my crappy usb cams.

any suggestions, anyone?

best regards


Nov 09 2007 | 8:48 pm

Nov 10 2007 | 7:28 am


I’ve had no luck yet.

The idea is to try out three cameras at the same time before buying expensive cameras.


Nov 15 2007 | 4:56 am

The icecam (for what it is) works great. I had one for my early work with Jitter and it was handy… but super low res. Definitely works with jitter but I don’t know if the drivers are UB.

Nov 15 2007 | 5:50 am

same problem here… mac will not read usb cam in jitter, only firewire, due to "priority" given to built in camera. the usb cam works fine with other apps.

Ive heard one poor work around is to use ichat to occupy the built in mac cam. i haven’t tried it.

does anyone know how to solve this?

thank you,

Nov 15 2007 | 12:21 pm

Yes, you can either open the jit.qt.grab help, click on get device list and see if your webcam shows up. You can also send grab the message "settings" to make sure the USB camera is connected by previewing it. Once you know it’s working try adding the arguement @vdevice to the jit.qt.grab object. I don’t know exactly how the numbers correspond to the ports but often it’ll just be the number 1 or 2 depending on how many cameras you have hooked up. Usually you have to make sure you have macam installed first.

Happy hunting.

Nov 15 2007 | 12:31 pm

i got the icecam, and it seems to work fine with jitter (although the quality is pretty low). the guy in the shop thought i would have a problem because of the built in isight, but it worked straight away when i plugged it in.
i’m using a macbook pro with an intel core 2 duo, running os 10.5, and using the driver that came on the disc with the camera.
i just go into the settings for jit.qt.grab and the icecam shows up as well as the isight.
maybe it’s an updated driver in leopard solving the issue with the the isight.

Oct 05 2008 | 5:31 am

i got it working using a generic (flex) web cam off ebay, maccam quicktime driver ( and jit.qt.grab. do as cap10subtext says and open the jit.qt.grab help file, set the "vdevice" integer to 2 or 3 or 4. try it until you get the video from the generic web cam…i sent "vdevice 3" message to jit.qt.grab, then send "open" message to jit.qt.grab and start the metro, viola.

Oct 06 2008 | 12:43 am

Bill Viola
Voila !

On 5-Oct-08, at 1:31 AM, Grant wrote:
> start the metro, viola.

Viewing 9 posts - 1 through 9 (of 9 total)

Forums > Jitter