Forums > MaxMSP

weird number~ and get info crash

Jan 25 2007 | 5:31 pm

hi there,

this is an odd one. it first occured in a patch i was working on but i’ve got it down to the bare essentials.
i open max. i create a new empty patcher. i put a number~ object in it and get info on the number~ object. i change nothing. i close the get info window. max quits.
not sure what on earth to do. i need to change the poll rate of a number~ object but can’t edit it.



powerbook g4 1.5 ghz
osx 10.4.8
max/msp 4.6.2

Jan 25 2007 | 6:19 pm

Jan 25 2007 | 7:05 pm

thanks leo,
that’s done the job for now :)


Jan 26 2007 | 10:30 am

a small development to this issue is that it seems to happen to all number inspectors, float, int and number~

don’t know what to make of it.


Jan 27 2007 | 3:38 pm

owen lloyd wrote:
> thanks leo,
> that’s done the job for now :)

It does not happen on my machine btw. with exactly the same specs (if
its a 12")

nonetheless, was audio switched on while the crash happened? You could
try with audio switched off. There have been bugs in the past, which
would crash while audio was on.


Stefan Tiedje————x——-
–(_|_ —-|—–|—–()——-
— _|_)—-|—–()————–

Jan 27 2007 | 10:17 pm

hi stefan,

there was not even a dac~ in the patch, just 1 number box, nothing else, in a new empty patch from start up. crashes every time i close the number inspector.


Feb 13 2007 | 6:14 pm

FWIW, I am experiencing this crash this morning. I’m in the middle of prepping to go teach a class. We’re going to run through Max Tutorial 11 among other things, so I was playing with the number box inspector. When I create a number box, if I open the number inspector, closing it causes Max to crash, whether I change anything in the inspector or not. Happens with int, float, and number~ and is reproducible. I have tried reinstalling MaxMSP & Jitter; that does not resolve the problem. This crash occurs as described by the previous poster, even in a new patcher window with nothing but the number box.

The issue does not appear in Max 4.5.7/Jitter 1.5 running on the same machine.

I’m running MaxMSP 4.6.2 & Jitter 1.6.2 on a 1.67GHz Mac G4 (OS=10.4.8).

Might be unrelated, but I’m also getting an error message on launch in the Max window that has not been resolved even after reinstalling Jitter:

Jitter 1.6.2 installed
/Library/Application Support/Cycling ’74/java/lib/jitter.jar
/Library/Application Support/Cycling ’74/java/lib/jode-1.1.2-pre-embedded.jar
/Library/Application Support/Cycling ’74/java/lib/max.jar
/Library/Application Support/Cycling ’74/java/classes/
? error: java.lang.NoSuchMethodError: copyMatrixToArray
Jitter Java support installed

Mar 09 2007 | 11:03 am

fixed it with a full delete of max/msp 4.5 and 4.6 and then a reinstall of 4.6.

this was done because of the adc~ fragload error, so i checked to see if the inspector was working ok. no crash :)



Viewing 8 posts - 1 through 8 (of 8 total)

Forums > MaxMSP