Forums > MaxMSP

Wii on Mac issues….!

Apr 11 2010 | 11:38 am

I’ve just started trying to use my wiiMote as a controller in max. I tried using aka.wiiremote – which i can get to connect to my wiimote; however no data is retrieved. Not even when i’m pressing the buttons! I tried "hi", and thisn will pull the information about buttons being pressed off the wiiremote, however i’m not getting any motion data, and its really that, that i need. Can anyone suggest where i’m going wrong?

Apr 11 2010 | 12:22 pm

are you using the latest version, namely the disis.aka.wiiremote version?
if not, get i from here:

I use it in 5.1.3 on 10.4.11 on intel and it works like a charm.


Apr 11 2010 | 12:27 pm

I’ve been using my wii controller with OSCulator into MaxMSP with great success. I’d recommend giving it a try.

Apr 11 2010 | 1:20 pm

I updated to disis, and managed to get the data out of it! Then Max crashed :-( ok well actually i tried to run multiple disis’s concurrently (as i want to use two wiimote’s) and then it crashed. Now I can’t get it to pair again.

I think its this process of connecting that i am having trouble with. My successes seemed to come when i tried using the bluetooth setup agent, and while it was trying to do its thing, i’d send connect on the disis object which would stop the blue tooth setup agent completing but the LED’s would stop blinking and data would be received in Max.

Is there some special technique, or something i’m doing wrong? I need to make the process stable and reliable….. I will try osculator in the mean time…

Again, thanks for your efforts so far… I

Viewing 4 posts - 1 through 4 (of 4 total)

Forums > MaxMSP