TouchOSC and Max5.1 not working?

    Dec 04 2009 | 9:36 pm
    I have been having trouble getting Max5.1 to receive any data from TouchOSC. Can someone please confirm whether or not there is a problem. I am using the latest TouchOSC running on iPhone OS 3.0. I am running one of the demo patches from the TouchOSC site.

    • Dec 04 2009 | 10:48 pm
      I am using TouchOSC with Max5.1 with no problems at all. for proof if you need it :)
      Are you sure you are setting the [udpreceive] port number to match the TouchOSC transmit port?
      Also, can you ping your iPhone's IP address from the machine you are running Max on?
    • Dec 05 2009 | 2:12 am
      I can indeed ping my iPhone from my laptop. The problem seems to be my connection in Max. I did make sure I am listening to the right port. The default port that TouchOSC sends on is 8000. But no data comes in...
      Eddy, what is your setup like? OSC external, iphone version, laptop OS, etc.
    • Dec 05 2009 | 2:50 pm
      Anthony, I am running Max5.1 and TouchOSC with no problems at all. I have a MacBookPro running OS 10.5.8.
      Have you tried the "Basic.maxpatch" file?
      Make sure: 1) your laptop and iPhone are on the same network, 2) the "host" field in the the TouchOSC app has the correct IP address for your laptop. It should be the same as the IPv4 address of your laptop (find this by selecting "network" in the system profiler). 3) the port (outgoing) value should use the same number as the argument to [udpreceive] in the maxpatch.
      Hope this helps, Mitch
    • Dec 05 2009 | 2:53 pm
      Anthony, One more thing, I assume that you have downloaded the CNMAT files and placed them in Max's path. get the link labeled "Everything for Max OSX (Mach / Universal Binary)". Unzip the files and then placed them into Max5's path. If you put them into the "/Applications/Max5/patches/" folder, it should work.
      Hope it helps, Mitch
    • Dec 05 2009 | 5:27 pm
      In response to "Eddy, what is your setup like? OSC external, iphone version, laptop OS, etc. "
      I'm running OS X 10.6.2 running on an 8 core Mac pro. I used an iPod Touch in the demo (latest available version of the firmware) and I tested it on a friends iPhone also (he updates the firmware regularly so pretty sure that'll be the latest version too).
      I don't use any externals at all. I use a [udpreceive] object in Max 5.1 (I have the iPhone set to transmit on port 7000 as it happens, but I also have a settings subpatch in presentation mode to configure that port at the Max end during runtime) and process the incoming osc using [gate] objects and [route]. It works perfectly for me - I'm sorry I'm not sure what is going on at your end there!
    • Dec 05 2009 | 5:30 pm
      What happens if you try this?
    • Dec 05 2009 | 10:05 pm
      Hey Eddy, I was about to send you guys the exact same code snippet. The above snippet DOES NOT work for me. I am running Vista (SP2), Max5.1, iPhone 3.0, latest TouchOSC. TouchOSC used to work fine before I upgraded to Max5.1.
      My guess is the windows build of Max5.1 has a problem. Can someone with a windows setup confirm this?
    • Dec 07 2009 | 2:16 pm
      Can someone with a windows setup please try this...
    • Dec 11 2009 | 6:47 pm
      it works fine.
      Maybe you have a firewall on?
    • Dec 23 2009 | 11:43 pm
      Hello everybody Hello Anthony, I am on a windows machine as well and also in trouble, that's how I found your topic. The strange thing about my situation is that I'm able to send from max 5 (with the simple-send-and-receive patch) and receive with my iphone 3G but not the other way around. After trying out some things I found my self in the situation that nothing worked as well. But I think I found the solution for this, maybe helpful for you:
      I found out that my wireless card (looking at the details of it) did not send and receive at all. I also have a wired lan connection so I thought, how does max/msp know which network to use? I disabled my wired lan network card and the maxpatch was able to send again trough wifi. But unfortunately still not able to receive...and also, it's not a real fine solution...
      I found out that my wireless card doesn't receive any data from the Iphone, so I thoughy maybe the host IP is incorrect. I use cmd and use the command: ipconfig /all to get the IPv4 from my wireless, double checked it, but no it's not the thing. Checked the ports, tried different ports. Tried with the windows firewall turned off... Also, my wireless is working fine with wifi internet connection... Now I'm out of idea's.
      using: updated version of windows 7 64bit TouchOSC 1.4.2 Iphone 3g v3.1.2(7D11) Max/msp/jitter 5.1.0
      greetings, Yurki
    • Dec 24 2009 | 3:50 am
      I also tried different ports, Firewall turned on and off, and still no communication with TouchOSC.
    • Dec 24 2009 | 9:12 am
      Somehow related: I downloaded max 5.1.1 today morning and something rather strange happened, my cpu went like crazy to 100% usage(the normal amount is around 10%). At the beginning I thought it was because of the metadata harvesting, but the problem continued for several minutes. I tried several times to reinstall the version but nothing seemed to work. I reverted to use 5.0.8. Maybe i am doing something wrong, is anyone here having similar problems? note: to check type top on your terminal or use the activity monitor Emmanuel
    • Dec 27 2009 | 12:04 am
      Well I finally found out what the problem was. For some reason, Vista reset all my port settings. I had to reopen them...