Trouble adding external objects


    Sep 03 2012 | 11:55 pm
    I'm trying out a demo version of Max 6. I've downloaded an external object that I need, OlaOutput. I cannot seem to get Max to recognize it. I used Options -> File Preferences... to set the path and it still does not show up in the Explorer. I tried some other objects and can't see them either. I tried pointing to the specific folders as well as copying the folder to ./examples. No luck. Is it a problem with demo mode or am I doing it wrong?

    • Sep 04 2012 | 2:21 am
      If I double click on OlaOutput.mxo and look at the Max window, I see:
      OlaOutput: unable to load object bundle executable
      2012-09-03 21:01:19.342 Max[385:c07] Error loading /Applications/Max6/externals/OlaOutput-0/OlaOutput.mxo/Contents/MacOS/OlaOutput: dlopen(/Applications/Max6/externals/OlaOutput-0/OlaOutput.mxo/Contents/MacOS/OlaOutput, 262): Library not loaded: /opt/loc
      al/lib/libola.1.dylib
      Referenced from: /Applications/Max6/externals/OlaOutput-0/OlaOutput.mxo/Contents/MacOS/OlaOutput
      Reason: no suitable image found. Did find:
      /opt/local/lib/libola.1.dylib: mach-o, but wrong architecture
      So the problem seems to point toward "/opt/local/lib/libola.1.dylib" but I don't know what this means...
      I'm reading this thread trying to understand: https://groups.google.com/forum/#!topic/open-lighting/D09-w7f-TGI
    • Sep 04 2012 | 7:15 am
      You must most probably install the OLA framework:
      p
    • Sep 04 2012 | 10:56 am
      @ Devo : same for the corresponding help files ? in different folders ? (like 'max' 'msp' 'jitter' 'maxhelp' 'msphelp' 'jitterhelp' for example ?)