udpsend problems


    Oct 27 2007 | 4:14 pm
    Hi all, There was a problem reported back in June with a similar error message that I am seeing using the udpsend object (here's the previous thread: https://cycling74.com/forums/index.php?t=msg&goto=108665&rid=15&S=81549daa51bd68a5df22c0f9b8a455f8&srch=udpsend+problem#msg_108665O)
    The error that I am getting is this: "error: udpsend: socket method unsuccessful"
    The previous post on this saw this error when sending too much data, and then crashes when saving. I'm getting this message based on time. I have a bunch of machines on a network doing some show control. The "master" controller sends out a message every 5 seconds via udpsend to the other machines to make sure they are still alive. I get this error message when the machine has been idle for several hours. The machine is set to never sleep and to never spin down. Once I get this error, the object is dead until I relaunch. The patch that it is in cannot be saved (nothing gets written/updated on the harddrive), and doing a "saveas" crashes max (as reported in the previous thread). Quitting also crashes Max after this message appears.
    Any ideas on what could be happening?
    Thanks, David

    • Nov 16 2007 | 11:52 pm
      Thought I'd try to get some help again. I'm still having the same problems where after a while (several hours) I start getting this message using the udpsend object:
      > "error: udpsend: socket method unsuccessful"
      My previous post explains this in a bit more detail.
      Any pointers would be greatly appreciated, as it is currently making my hair considerably grayer than it already is!
      Best, David
    • Nov 18 2007 | 12:49 pm
      Do you have the possibility to make an example patch with clear steps to reproduce?
      Mattijs