Ultrasonic Range Fiders

    Dec 08 2013 | 12:30 am
    This may be a question that there has been an answer to, but I need the help. I recently set up a sound installation using six different Maxbotix Ultrasonic Range Finders controlling various parts of the sound. When I built the patch I tested it out using Maxuino which I could not figure out at all, then I tried them again with Arduino2Max and they worked great. When the update for Max came out that allowed it to work with Mavericks I made the update to mavericks and when I did the actual installation the input numbers from the range finders went berserk. They didn't read any ranges accurately, even when hands were set right in front of them, and I ended up having to do a complete reset of the concept using counters to simulate the ideas. I've been trying to figure out what happened and the current ideas are that the space did not allow for the sensors to work. The space I set up in used to be a gym and has horrid pingpong issues for sound (parallel walls) so we hypothesized that the sensors were picking up too many sound artifacts to accurately read the room. The other thought is that something went wrong with Arduino2Max when I made the switch over to Mavericks. Any thoughts about what went wrong? I would love a patch that is more customizable then Arduino2Max or advice on creating one to read my controllers. I was using the Maxbotix EZ0 and an Arduino Uno with the microcontrollers plugged into A0-A5.