umenu alphabetizing issue

    Oct 23 2009 | 6:50 pm
    I have a umenu for selecting a large list of videos in a folder, and one particular folder has issues with alphabetization in the umenu and I cannot figure out why. It's a folder of about 78 files.
    I initially thought it might be an issue with formatting of the text, but I replaced all spaces with underscores and got rid of any other funky characters, and the entire file name listing in the umenu inspector didn't have any items with "quotes" around them, but it still was not alphabetized correctly (the ordering seems to be completely random). Other umenus in my same patch have mixtures of "quoted" items and non-quoted, but this folder in particular seems particularly stubborn.
    Any suggestions? I've tried recreating the menu in other patchers, but i guess I could start a new folder, adding each single file until it breaks the alphabetizing. Is there a message to sort of force the alphabetization of a umenu?

    • Oct 23 2009 | 7:27 pm
      on more inspection, I've found that moving the same files to a different folder does the same thing..even if I create a folder with like 5 files, it still does not order them correctly
      I'm not sure if it makes a difference, but everything is currently on a fat32 formatted external usb drive and I am using a mac with 10.5.8...could the different file systems be to blame somehow?
    • Oct 23 2009 | 10:31 pm
      What happens when you drop this particular folder onto the [dropfile] object in the [prefix-settings] subpatch of the [umenu] help file? If it works properly here then you could perhaps post your patch here so people can have a look and see what is causing the problem. If it doesn't work then I'm not sure what to suggest.
    • Oct 24 2009 | 6:49 am
      Thanks for the suggestion, but I get the same problem in that patch...I'll have to see what it does when I move it off the fat32 drive..perhaps there is some sort of strange bug there
      EDIT: i just did a test where i made aliases of all of the files in the folder..made a folder on my internal drive and copied the aliases to that..and voila, the alphabetization worked fine in the umenu help patch/my must be this drive being formatted as ms-dos/FAT and some different way it designates characters..i guess ill have to back it up and reformat to fix the issue
    • Oct 24 2009 | 7:11 am
      Additionally, one of the features of OSX is that Finder does not necessarily deal with items in alphabetic order. For instance, in the Automater application, there is an action named Sort Finder Items which can be used after selecting for instance the content of a folder. I remember vaguely having constructed a sorting mechanism in max and have noticed in relation with other applications that drag and drop of multiple items causes random order. Recently, however, I was populating a umenu and did not have this issue.
    • Oct 24 2009 | 9:35 pm
      You can use zl sort in any case to make sure that the menu is alphabetically ordered if that's critical for your use.