Undoing a saved patch...

    Dec 03 2009 | 12:41 am
    Hi All,
    I've posted on the ableton forum but i'm hoping an expert has a great answer for me..... Tone Deft's suggested deleting the preferences file for ableton so i've done this and tried to open the patch in both 8.1 and the latest beta, unfortunately neither worked....
    I made an error in connecting a loadbang effectively back to itself so that when i try and open the patch for editing it just hangs and i have to forcequit to get out of it...
    Is there anyway to open the patch without it being activated so that i can delete the patch cord and finish my patch?
    Cheers D

    • Dec 03 2009 | 12:46 am
      You can disable loadbang by pressing command+shift when loading a patch (ctrl+shift if you're a on windows).
    • Dec 03 2009 | 12:49 am
      You my sir are my absolute saviour!!! Thank you so much!!
      Cheers D
    • Dec 04 2009 | 9:07 pm
      If you do create a feedback loop that is triggered by loadbang then instead of hanging you should get a stack overflow -- it shouldn't hang but instead it should disable outlets in the patcher until the error condition is cleared. Please try and post a simple patcher that we can reproduce the problem with so we can see if there is something we should fix.
    • Dec 05 2009 | 2:35 am
      I managed to get out of it with the tip above, the patch is so complicated that i'm not sure exactly why it happened.... When i did eventually get a stack overflow i was still stuck with no response when trying to open the editor though...
      Cheers D