Unexpected behavior from Max Runtime app (Max6)

    Dec 13 2012 | 9:18 pm
    I confess that I've never used the Runtime app before and I appear to be doing something wrong... My plan was to provide my performers with a copy of Max Runtime along with a folder containing all the patches, subpatches and data files needed for the piece. When I start up Max Runtime the application launches but all I get is a menu saying Max Runtime. There is no File menu etc. (I discovered that the same thing happens if I move the Max Runtime app out of my Max folder and try to launch it.) I tried it on a computer that didn't have Max installed and if I double-clicked on a patch file, it would launch Max Runtime (with no menus) but none of the text buttons etc. were functional (all there were were some grayed-out references to text buttons)
    Do I have to include additional files from the Cycling74 folder in order to get the Runtime app to work properly?

    • Dec 13 2012 | 10:13 pm
      OK, I discovered that I needed to build a collective. When I built it I included all the additional bpatcher files. Now the patch appears with active text buttons etc when I double-click it on a machine containing only Max Runtime. Unfortunately it still doesn't work. The patch accesses sound files that live in a separate folder. My main patcher creates relative filepaths to this folder and it's tested out OK within Max on multiple machines, but when I try it using Max Runtime the sounds won't play. I tried creating a collective including all the sounds and it still doesn't work.
      Can anyone help?