URGENT!!!! M4L devices not opening anymore!!??

    Aug 24 2013 | 2:57 pm
    Been a couple of months since I used M4L, and now, all of a sudden, I can't open any M4L devices anymore! I tried updating both Live 9 Suite and Max to the latest versions, but to no avail. I'm running Max in 32-bit mode, so that shouldn't be the issue, either. I'm not getting any error messages, the only thing that happens is that the device grays out, and the little yellow icon spins and spins, and the text at the bottom keeps saying "Starting Max Editor"... The devices work fine, the only thing is I can't open them in Max. It's all very mysterious.
    Sys specs: Max 6.1.3, Live 9.0.5, MacBook Pro i7 2.66 GhZ, OSX 10.8.4

    • Aug 25 2013 | 6:43 am
      You can try to switch to max from the dock then go back to live. Sometimes it cures the 'never opening syndrome' for me.
    • Aug 25 2013 | 7:13 am
      Nope. Doesn't seem to cure anything for me, unfortunately...
    • Aug 25 2013 | 7:20 am
      I recommend to contact ableton support about it. It should be an easy fix (usually).
    • Aug 25 2013 | 7:23 am
      Yes, I've sent them a mail. Hope they'll get back to me soon...
    • Nov 14 2013 | 4:57 pm
      Hi Kflak, I am having your problem too. How did you resolve it please?
    • Nov 14 2013 | 6:59 pm
      Hi Jussy, I solved it by deleting the entire harddrive, reinstalling osx and then reinstalling the contents of the harddrive from timemachine backup. Normally you should be able to fix this by repairing permissions, but there seemed to be some very low-level corruption going on in my system that just wasn't possible to fix that way. So brute force it was that fixed it in the end. Good luck!!!
    • Nov 15 2013 | 3:33 pm
      Thanks for that Kflak. Wow.. prety drastic. For what it is worth, I can open smaller patches such as the factory ones, but I am getting the above with my own rather larger ones. Through much messing about with the clipboard and Max already open in the background, I can just about get them to open, but not really to the point of functioning properly. Live likes to show 20% CPU, but I get 200% in Activity Monitor plus full speed fan on my MBPr....
    • Nov 17 2013 | 5:43 pm
      Yes, it was a big operation, but it also solved some other long-standing issues I had with various stuff, so it was totally worth it :-) The best advice I have, though, is to contact Ableton support. They are very friendly and mostly very helpful… Sounds like your issue is very different from mine. I couldn't open any live devices, but they were running just fine in my Live set. Nobody's been able to figure out what exactly was wrong...
    • Nov 18 2013 | 10:00 am
      Thanks Kflak. Yes, I have been waiting for a reply from Ableton for a few days now...