user interface becomes slow because of sonogram

    MaxMSP

    Edwin van der Heide's icon
    Edwin van der Heide's icon
    Edwin van der Heide
    Sep 23 2013 | 9:55 pm
    The Max user interface becomes rather slow when I use the spectrogram object in sonogram mode. I'm curious why this happens since I would expect that displaying the sonogram is not a lot of drawing work (I'm not even using the scrolling mode).
    The patch below has two rather large sonogram objects. When I change the number box that controls the frequency of cycle~ with the mouse I'm getting slow update rates (around 180 ms). I'm curious to know if this can be resolved. (max 6.1.3 on 10.8.5)
    Max Patcher
    In Max, select New From Clipboard.
    Show Text
    Best! Edwin

    • Floating Point's icon
      Floating Point's icon
      Floating Point
      Sep 24 2013 | 6:24 am
      maybe increase your signal vector size (options->audio status)?
      btw the update speed of a number box wont be any more than your mouse 'refresh' rate
      Share
    • Edwin van der Heide's icon
      Edwin van der Heide's icon
      Edwin van der Heide
      Sep 24 2013 | 4:47 pm
      The signal vector size has no effect on this.
      I understand the mouse refresh rate. The problem I experience is not related to this.
      It seems that updating the screen takes a lot time...