vipr and next-gen codecs (HEVC/h.265 and VP9)

    May 13 2014 | 10:45 pm
    Hi all,
    I was wondering if anyone has had any success trying to get either HEVC/h.265 or VP9 to work with Benjamin Day Smith's vipr object. Since vipr is a wrapper for FFMPEG's libavcodec, I would figure that codecs supported by libavcodec could potentially work in vipr. According to the list of Libav supported codecs, Libav supports HEVC decoding natively and encoding "through the external library libx265." VP9 is in a similar situation - native decoding support, and "encoding supported through external library libvpx."
    Instructions to install libvpx via git are here. Info how to build libx265 can be found here. I tried installing both libvpx and libx265, and the shell install processes seemed to be successful (although I haven't tested the codecs otherwise, e.g. by trying to encode to h.265 or VP9 using another application). When I try to load VP9 and h.265 in vipr, though, I still get a "codec not found" error in the Max window.
    Benjamin mentions that some of the codecs made available through vipr are encode- or decode-only, so is part of the problem perhaps that vipr just isn't aware that libvpx and libx265 are installed? Is there a way of fixing this from the user's position, or would it be necessary for the vipr object to be modified (or for FFMPEG to update libavcodec)?