vst program changes w. PSP vsts

    May 25 2006 | 6:18 am
    Hello, I'm testing out some demos of the PSP effects VSTs (PSP 608 Multi Delay, etc), and having trouble sending program changes (but not parameter changes). Sending ints to the inlet of the vst~ object just gets a report that "program [insert random int here] outside effect's range". Is anyone able to get these plugs to see program changes under OS X?
    Since I haven't used that many vsts, but had this problem with another plug, I'm wondering: anecdotally speaking, are there many widely available plugs that don't see program changes within msp, or is it just my bad luck?
    Thanks, Michael

    • May 25 2006 | 7:45 am
      so vsts as I know them actually only have 1 program and that is all, each one I think is hardcoded at init time to have a certain number of presets available. Some use different patching algorithms other than steinbergs fxb or whatever it is. An example would be like oxeFM synth or quadraSID, which both have 0 programs available via program changes, but, both have alternative menus to browse through presets.. (why I don't know)...
    • May 25 2006 | 7:54 am
      Not sure if it's relevant here, but I've found that within vst~, some plugs respond to a 'normal' (midi formated, ie. 192 i ) program change message, whilst others, notably Pluggo's, require a simple int. cheers Roger
    • May 26 2006 | 12:40 am
      VST plug-ins in general do not "have" (midi-)progams, and therefore do not recieve program change via midi. there might be exceptions.
      if it works in certain apps, this is controlled by the host.
      you can do this translation from program number to vst preset number in maxmsp easily by yourself, isn t it?
      i would recommend to use *bank select* for *vst presets* rather than *program select*
    • May 26 2006 | 12:43 am
      eh, you were not asking for midi but for switching presets so disregard the above.
    • May 26 2006 | 8:07 pm
      Thanks for all the replies. It turns out that preset changes aren't supported for these plugs, which is a cryin' shame, as they sound really great. I tried to cheat by sending a 'param' message, recording the values, and feeding them back in. That doesn't work either, as sending a message such as "3 0.5" apparently just sets that parameter to 0 (with these plugs). Oh darn. I haven't been that excited about the sounds I was getting from an off the shelf product like this in some time, but I need to be able to automate the rapid switching of presets....
      thanks again, Michael
    • May 27 2006 | 12:52 am
      could you tell me which are the ones which do not work for you?
      i just tried the ones which are available for OS 9 on OS 9.
      switsching works, but it is very slow! up to 10 seconds! it is much better when the GUI of the plug-in is in foreground, but that ddoesn t help us with this weird problem.
    • May 27 2006 | 12:59 am
      anno, now i have it :P
      the preset change is only executed on mouse-over over the plug-in GUI (of psp-42/84 in that case)
      so it is the plug-in s fault ... though it does not happen in nuendo, cubase, and logic (4.8 classic)
    • May 27 2006 | 5:47 am
      the real bummer is that the psp "608" plugin will actually report param values, and allow you to send messages to set param value. in lieu of being able to change presets, this is a good kludge. however, as mentioned before, for some reason (incomplete implementation of the vst spec!, ahem) this doesn't work on the 42/84 plugs. hello people, just throw in the same param reading code and fix it, or better yet, support preset changes like a well behaved citizen!
    • May 28 2006 | 3:33 pm
      today i tried 42/84 it again - and it works ... with both, edit window open and closed.
    • May 28 2006 | 3:59 pm
      not all of the reported parameters are stored to preset in the PSP plug ... that is nothing unusual but might cause you trouble in MAX.
      the "repeat infinite" VST parameter for example does not go into edit presets ... and is even set back to "0." (turned off) after sending the bypass message to [vst~] (or the equivalent VST message in a steinberg host)
      maybe that is what is confusing you, besides all those wrong assumptions i made in my last posts.
    • May 29 2006 | 6:39 pm
      Hi Roman, I tried to email you about this offlist via the forum's email option, but there was an error that said it couldn't determine your email address.
      In any case when you said re: the 42/84 vsts that you were able to get them to work, what exactly were you referring to? I.e., were you able to get them to change presets from Max? Or were you able to send parameter values from Max and have the plugs respond? I'm currently not able to do either under OS X 10.3.9, and working with the demos. Do you have an example patch that you could send me? thanks!, Michael
    • May 30 2006 | 12:38 am
    • May 30 2006 | 8:53 pm
      Quote: Roman Thilenius wrote on Mon, 29 May 2006 18:38 ---------------------------------------------------- > email via forum should work. (just got another one yesterday) > > well, i dont know what i did wrong two days ago, but > yesterday my psp-24 and psp-84 plug-ins _did "work" > in MAXMSP 4.1, where "works" means that i was playing > audio though it, and the effect on the audio immediately > switches to the second preset of the plug-in when i send > a message "2" to the [vst~] object, like it should do, > and does in other plug-ins too. >
      very strange- when i send a message of 2 i get the error message "program 2 outside effect's range"...
    • May 30 2006 | 10:09 pm
      >> very strange- when i send a message of 2 i get the error message "program 2 outside effect's range"...
      oops. what about other hosts. maybe the new demo versions do not have programs ? :)